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 Introduction to CSiCol 

CSiCol is a comprehensive software package for analyzing and designing concrete, reinforced 
concrete, and reinforced concrete composite columns. CSiCol’s Quick Design Wizard provides 
access to all the forms needed during the column design process, making design simple, organized 
and efficient. The design can be completed in accordance with user-specified codes. Analysis and 
design are interactive. Figure 1.1 illustrates the overall design and analysis process using CSiCol.  

The program can design the column cross-sections for specified axial loads and moments directly 
or can compute the magnified moments caused by slenderness effects. An unlimited number of 
load combinations can be defined, both for sway and non-sway conditions. Sway and non-sway 
condition checks may also be performed as specified in the selected design code. In addition, 
CSiCol is capable of determining the Effective Length Factor on the basis of a column’s framing 
and end conditions. An auto design tool helps in automatically selecting the optimum reinforcement 
for specified actions using user-defined rules.  

The program can generate a wide variety of results. Output includes the capacity interaction 
surface, PM curves, MM curves, moment-curvature curves and flexural stress contours among 
others. Reports may be created as part of the output for the analysis and design process. The reports 
may be customized by adding information and graphics of your choice.  

The program provides several predefined parametric shapes, including a variety of solid, hollow, 
and flanged shapes, in addition to a large collection of Standard Steel Database Shapes that can be 
used in composite columns. Merge, edit and draw Shapes to suit your geometry requirements and 
create complex cross-sections. The program provides effective, efficient and practical tools for 
aligning, stacking, and placing shapes. Rebar can be placed anywhere in the cross-section in any 
patterns such as point, line, rectangle and circle as required using several drawing and placement 
tools. Several standard (ASTM, Metric, and Imperial) and user-defined rebar sets may be used.  

1.1. Compatibility with CSiCol v9 
CSiCol files saved in version 9 (.cdb files) can be imported to CSiCol v10. Multiple columns can 
be imported, and the columns are imported along with their framing conditions, loadings, material 
assignments and slenderness properties. By default, the working units will be the same as that used 
in the older version of CSiCol. As of now, only US (inch) and SI (mm) unit systems are supported 
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in this version of CSiCol. . If the units in the CDB file are in any other system, it will be converted 
to either US (inch) or SI (mm) unit system.  If the CDB file uses an older version of the design code 
available in CSiCol v10, it will open with the new version of the design code. 

 

Figure 1.1 Overview of CSiCol Design and Analysis Process 
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1.2. Key Features 

1.2.1. Design and Analysis Capabilities 

• Use the Quick Design Wizar0d capabilities to guide you through the entire column 
design process.  

• Import columns from ETABS along with the materials, sections, loads and framings 
• Design columns in accordance with user-specified codes.  
• Define any number of load combinations for sway and non-sway conditions.  
• Apply loads in detailed and simple mode for slender and short columns respectively.  
• Perform analysis and design considering slenderness effects.  
• Use Auto Design feature to determine the optimum reinforcement to satisfy user-

defined parameters. 

1.2.2. Slenderness Considerations 

• Define the framing or import it from either ETABS or CSiCol v9. 
• Perform code-specific sway and non-sway condition checks.  
• Use the program to determine the Effective Length Factor on the basis of the framing 

and end conditions.  
• Perform analysis and design considering slenderness effects.  

1.2.3. Cross-Section Generation  
• Define and edit multiple column sections at the same time.  
• Create rectangular and circular columns using simple tools.  
• Use any of the predefined parametric shapes, including a variety of solid, hollow, and 

flanged shapes, in addition to a large collection of Standard Steel shapes.  
• Import shapes from text files and .DXF Files 
• Import sections from ETABS or CSiCol v9 files. 
• Create and then edit complex column sections by combining basic concrete shapes, 

basic steel shapes, standard steel shapes and user-defined shapes.  
• Merge shapes of different geometry to create complex shapes.  
• Add rebar of any size anywhere in the cross-section using several rebar patterns. 
• Apply ASTM, Metric, Imperial or user-defined rebar sets. 

1.2.4. Material Properties 

• Realistically model various materials using the stress-strain curves available in the 
program for concrete and steel.  

1.2.5. Results Generated 
• Compute and report basic geometric properties, such as area, moments of inertia, shear 

area and rebar area.  
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• Plot the flexural stress resulting from actions (P, Mx, My) on a column's cross-section.  
• Generate capacity interaction surfaces and diagrams.  
• View capacity details of the P-M diagram such as axial load, major axis moment, force 

and moment on concrete and rebar, strain, etc at various neutral axis depth. 
• Plot multiple P-M or M-M curves in the same graph with varying values for either 

Compressive Strength of Concrete (fc’), Steel Tensile Strength (fy) or rebar sizes. 
• Generate moment-curvature curves for any arbitrary column shape to determine 

performance and ductility.  
• Display the location and orientation of the neutral axis corresponding to a specific 

loading.  
• Compute capacity ratios based on different methods and determine adequacy of the 

section for the specified loads. 
• Design the column in accordance with the specifications of the selected design code.  

1.2.6. Miscellaneous 
• Model composite cross-sections using several materials. 
• Set the working units to US or SI.  
• Use the comprehensive Help to apply the program efficiently.  
• Create detailed, customized reports by adding information and graphics.  
• Display a summary of some critical information regarding all the columns such as the 

governing load, rebar configuration, rebar ratio and the corresponding D/C ratio. 
• Generate a one-page report for all the columns in the Project File. 

1.3. Terminology 
Some important terms that require clear understanding to help make the program more useful are 
defined below: 

• Project File is where newly defined or pre-created columns can be saved for later use. 
Several columns can be added to an individual Project File. 

• Column is a complete member with a cross-section, framing condition and load 
combinations. Several tools are available to create columns from within the File Menu 
including Quick Design Wizard, Rectangular, Circular, Blank, Import ETABS and 
Import CDB.  

• Section is a combination or collection of shapes placed together to act as a single cross-
section. Properties are computed and the design is completed for a section and NOT 
for a shape (unless a section has only one shape). Figure 1.2 shows a section made up 
of 2 shapes. 

• Shape is the basic component that is used to create sections. Rebar can be added to 
individual shapes or anywhere in the section. Predefined shapes from standard libraries 
can be used and modified to create sections. Several tools are available to create shapes, 
including the File Menu>Rectangular, the File Menu>Circular, the Draw 
Menu>Concrete Shapes, the Draw Menu>Steel Shapes, the Draw Menu>Add 
Shapes>Shape Library, the Draw Menu>Add Shapes>Steel Shapes and the Draw 
Menu>Add Shapes>Coordinates buttons. Shapes can also be imported from a .txt file 
or a .DXF file using the tools available under Draw Menu>Import Shapes. 

• Shape Library is a collection of standard predefined shapes that can be edited 
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parametrically (e.g., specifying dimensions) or imported from standard databases. The 
software includes several libraries. 

• Modes: You can switch between three different modes in CSiCol which are as follows: 
1. Selection Mode is activated when the Edit Menu>Select button is clicked. While 

in selection mode, you can select various shapes in a column section but cannot 
edit the shapes using the mouse. However, shapes can be edited using the Property 
grid that gets activated in the Selection Mode. Shapes can be aligned using the 
various buttons available in Edit Menu>Align and moved using the Edit 
Menu>Edit>Move Sections button while in the Selection Mode.  

2. Drawing Mode is activated when the drawing options for rebars or basic concrete 
and steel shapes are selected from Home Menu>Draw>Rebars, Home 
Menu>Draw>Shapes, Draw Menu>Rebars, Draw Menu>Concrete Shapes or 
Draw Menu>Steel Shapes. While in the Drawing Mode, the cursor in the working 
area changes to +. Multiple objects can be drawn in the Drawing Mode. The 
Drawing Mode can be exited by pressing the Esc key. 

3. Results Mode is activated when the results for the column section are viewed from 
the Results Menu or from the Project Explorer>Columns>Results. When this 
mode is active, the user is not allowed to make any changes to the section. 
Therefore, the tools under the Edit Menu and the Draw Menu are inactive in this 
mode. To exit the Results Mode and make changes to the section, select the desired 
section from the Project Explorer>Columns. 

• Axis: Various editing operations, computed properties, and shape locations are 
referenced to the global X and Y axes. These axes help locate the shapes properly by 
providing a common origin. Two pairs of axes are used in the program. The first pair 
is X-Y, which is a global fixed reference on the screen. The second is the 2-3 coordinate 
system, which indicates the location of the section's centroid. The 2-3 axes origin keeps 
changing with changes in the shape's size and location. This system is provided to be 
compatible with the member local axis system used in CSI's SAP2000 and ETABS 
programs. In those programs, the 1-1 axis is used as the axis that passes through the 
members' longitudinal axis. A section showing the local axes is presented in Figure 
1.3. 
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Figure 1.2 Section made of 2 Shapes 

 

Figure 1.3: Section in 3D showing local axes 

1.4. Results and Output 
CSiCol generates the following types of results: 

• Section Properties 
• Stress Distribution  
• Magnified Moments 
• Section Capacity 
• Moment Curvature 
• Multiple Curves 



User’s Manual and Technical Reference Introduction to CSiCol  

Results and Output  7 

 

1.4.1. Section Properties  

The software reports the following properties for the section: 

• Basic Properties: Includes the area, shear areas, moment of inertia and torsional 
constant of the selected section. 

• Section Bounds: Includes the overall dimensions of the selected section and the 
centroid location with respect to both the global origin as well as the local origin. 

• Additional Properties: Includes the radii of gyration and section moduli of the selected 
section. 

• Rebar Properties: Displays the rebar area and rebar ratio in the selected section. 

Note: For composite sections, concrete is considered as the base material and the 
transformed section properties are reported. 

1.4.2. Stress Distribution  

The program can display the Flexural Stress on the section for the selected load combination and 
section location. The stress is displayed independently as 2D or 3D color-coded contours on the 
working area. 

1.4.3. Magnified Moments  

The program performs detailed slenderness calculations to obtain magnified design moments, both 
for sway and for non-sway loading, in accordance with the procedures specified in the relevant 
design code. The final design loads can be viewed by using the Results Menu>Design Loads button 
or the Project Explorer>Columns>Results>Design Loads which gives access to the Design Loads 
form. Select the loading direction (Along X or Along Y) by clicking on the respective tab to view 
the loading in the desired direction. The moments under Along X and Along Y tab correspond to 
the moment about the X-axis and the Y- axis respectively. 

The magnified moments are calculated based on the selected design code. Currently, the following 
design codes are supported for magnified moments calculation: 

• ACI 318-08 
• ACI 318-11 
• ACI 318-14 
• IS 456:2000 
• CSA A23-3-04 
• BS 8110-97 
• Euro Code 2: 2004 

1.4.4. Section Capacity 

The section capacity can be obtained in one of the following three ways:  
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• P-M Interaction Curves  
The capacity interaction curves are displayed as follows:  

• Interaction Surface: The variation of all three parameters governing the section 
capacity (the axial load P, moment M2 and moment M3) of a column section is plotted 
in a color-coded 3D graph. 

• P-M Curve: Load-moment interaction curves showing the relationship of axial load 
capacity and resultant moment capacity for a specified angle of neutral axis.  

• M-M Curve: Moment-moment interaction curves showing a plot between moment 
capacity about the local 2-axis and moment capacity about the local 3-axis at a 
specified axial load level.  

Note: Although the program can generate capacity curves for any section and combination 
of different shapes and materials, it is important that the user use this information with the 
proper understanding and check the validity and applicability of such calculations.  

• Capacity Ratio Check 
The program is capable of calculating and reporting the capacity ratios for column 
sections using three different methods (Moment sum at P, Moment Vector at P and 
Axial Capacity Ratio). In addition, the program can display the resultant moment and 
resultant moment angle. The program also reports whether the section is or is not 
adequate based on the maximum value of the capacity ratio calculated from different 
methods. For capacity ratios greater than one, the program reports the section as 
inadequate.  

1.4.5. Moment Curvature  

The moment-curvature curves may be plotted for any orientation of the neutral axis and for a 
specified level of axial load.  

1.4.6. Multiple Curves 

The program can generate multiple P-M or M-M diagrams in the same graph with varying values 
for either Compressive Strength of Concrete (fc’), Steel tensile strength (fy) or rebar sizes. 

1.5. Auto Design 
The Column Auto Design feature is a very effective, efficient and powerful tool for designing 
reinforcement for sway and non-sway columns with or without considering slenderness effects. 
The Column Auto Design tool designs the section according to the various design parameters 
defined/specified by the user, including design codes. The program optimizes the design of the 
columns for a user-specified maximum capacity ratio limit. Limits may be imposed on the 
maximum and minimum rebar size and maximum rebar ratio used in the section. This feature is 
explained in further detail in Chapter 3. 
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1.6. Other User Support Documents 
In addition to this manual, support documentation includes a help file. The support documents are 
available with the purchase of the program or can be ordered independently. For more details, visit 
www.csiberkeley.com, or email support@csiberkeley.com.   
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 CSiCol’s User Interface 

CSiCol’s user interface is highly user friendly and intuitive. The interface consists of a working 
window with various menus. Figure 2.1 shows CSiCol’s main screen. The components of the 
interface are described in this chapter. 

2.1. Working Window  
The CSiCol graphical user interface is shown in Figure 2.1. It includes the main window, title bar, 
ribbon menu, project explorer and context-sensitive area. Each of these items is described in the 
bulleted list that follows. 

• Main Window 
This window may be moved, resized, maximized, minimized, or closed using standard 
Windows operations. Refer to Windows help available on the Start menu for additional 
information about these items. 

• Main Title bar  
The main title bar includes the program and model names. The main title bar is 
highlighted when the program is in use. Move the main window by left clicking in the 
main title bar and holding down the mouse button as you drag the window around the 
computer screen. 

• Ribbon Menu Bar  
This menu bar contains the program's menus from which various sub menus can be 
selected to perform specific actions. Such as File, Edit, Define, Draw, Results, Options 
and Help. 

• Working Area 
All creation and modification of shapes and sections take place in the working area. 
CSiCol automatically updates the working area as shapes are added, moved, resized, 
rotated and combined to create new sections of arbitrary geometry and size. The 
working area is filled with a “graph paper” type grid that is useful for placing, aligning, 
and resizing shapes and sections. 

• Project Explorer  
The project explorer has 4 main views namely Materials, Stress-Strain, Columns and 
Report. The first two views of this explorer allow easy access to view and modify the 
properties of the materials and stress strain curves defined in the project file. These can 
be used for any of the columns in the project. Under the Columns view, the shapes, 
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rebar patterns, framings and loadings of all the columns in the project file can be 
accessed and modified. The results for the columns can also be accessed under the 
Columns view for each specific column. The Report view can be used to generate a 
one-page and the detailed report for the selected column. 

• Context-sensitive Area 
This area contains the context-sensitive grids that get activated in response to the user 
action. Different grids get activated based on what button the user clicks or which 
shape the user selects. For example, the Property grid gets activated in this area when 
a shape or rebar is selected. 

 

Figure 2.1: CSiCol Working Window 

2.2. Customize the Program 
This section briefly describes the different settings available under the Options Menu. CSiCol 
provides different settings to modify the different parameters used globally in the current Project 
File. Those parameters include the working units, the design code, view options, number formats 
and other display settings. These options have been placed under the Options Menu on the Ribbon 
Menu Toolbar. 

2.3. General Options 
The parameters that affect all the sections globally in the current file (i.e., working units and design 
code) can be set using the General options. 

• Units Drop-down list: The Units drop-down list identifies the various units available 
for use in the model. The selected units apply globally to all the sections in the Project 
file. Currently, US (kip-in) and SI (N-mm) units are available. 

• Code Drop-down list: The Code drop-down list identifies the design codes available in 
CSiCol. Select the desired code from the drop-down list by clicking on it. The specified 
code will be used to calculate the various parameters needed to generate the Capacity 
Interaction Surface and Moment-Curvature relationships. Those parameters include 
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capacity reduction factors, cutoff values for axial compression, maximum allowable 
strain in concrete, and material reduction factors. Updating the design code will erase 
all previous results. So, the user will be asked to confirm before changing the design 
code. 

• Rebar Sets button: The Rebar Sets button gives access to the Add Rebar Sets form 
where new rebars can be added and existing ones removed. New rebars can be added 
either by clicking on the  button and manually inputting the name and diameter of 
the bar or added from standard libraries such as ASTM by clicking on the Add button. 

2.4. Number Formatting Options 
The settings related to the number formats used to display all the numerical values in the Project 
file are grouped under the Options Menu>Number Format.  

• Decimals Drop-down list: Use this drop-down list to change the number of decimal 
places to be displayed for all the numeric values. 

• Separator Drop-down list: Use this drop-down list to select different separators for 
thousands and decimals. 

• Show Exponent button: Turn on the Show Exponent toggle to display the numeric 
values in exponential notation. 

2.5. View Options 
The settings to show or hide various elements of the working area such as grid, ruler and global 
axis are grouped under the Options Menu>View.  

• Grid button: Use this toggle to display or hide the grid in the working area. 
• Ruler button: Use this toggle to display or hide the ruler in the working area. 
• Global Axis button: Use this toggle to display or hide the global x and y-axis in the 

working area. 
•  Dimensions button: Use this toggle to display or hide the dimensions of the shapes 

and rebars in the working area. 

2.6. Diagram Options 
The settings to display the points and labels of diagram data are grouped under Options 
Menu>Diagrams. See section 5.6 of this manual for more details. 

• Points button: Use this toggle to display or hide the data points in the diagrams. 
•  Labels button: Use this toggle to display or hide the data point labels in the diagrams. 
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 Designing Columns 

This chapter describes how to use CSiCol to quickly create column sections and compute their 
capacities. It also describes the design process. It is highly recommended that users read this chapter 
before using the program. It has been assumed that the user is familiar with the basic concepts of 
structural mechanics, structural analysis and the process of column design. 

3.1. Column Design Problem 
The design engineer must determine the appropriate dimensions, cross-section shape, material 
characteristics, and amount and distribution of reinforcement for a column on the basis of a set of 
applied actions, the column geometry and the framing conditions. CSiCol provides convenient tools 
to determine the most effective and efficient parameters for a given set of applied actions. Those 
tools include, among others, the Quick Design Wizard, Shape Libraries, Rebar Patterns and the 
Auto Design feature, which are described in the subsequent sections of this chapter. Tools for 
editing shapes in a section are described in Chapter 4. 

3.2. Methods for Creating Columns 
Columns can be created using the following methods:  

• File Menu>Quick Design Wizard button: This accesses the Quick Design Wizard. The 
Quick Design Wizard form provides access to all the forms needed to complete the 
entire column cross-section modeling and analysis process, including defining column 
framing and loading and generating results and reports. This is the “default process” 
for creating rectangular or circular columns.  

• File Menu > Blank Model button: This opens a blank working area that can be used 
to create a column of any shape. Shapes must be added to the column using the button 
under the Draw Menu and modified to obtain the desired section using the buttons 
available under the Edit Menu. Defining the column framing and loading and 
generating results must be completed independently using the various buttons available 
under the Define Menu and the Results Menu. Reports for the column can be viewed 
using the buttons available under the Home Menu>Report or from the Project 
Explorer>Report. 

• File Menu > Rectangular Model button: This can be used to create a rectangular 
column. Defining the column framing and loading and generating results must be 
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completed independently using the various buttons available under the Define Menu 
and the Results Menu. Reports for the column can be viewed using the buttons 
available under the Home Menu>Report or from the Project Explorer>Report. 

• File menu > Circular Model button: This can be used to create a circular column. 
Defining the column framing and loading and generating results must be completed 
independently using the various buttons available under the Define Menu and the 
Results Menu. Reports for the column can be viewed using the buttons available under 
the Home Menu>Report or from the Project Explorer>Report. 

After a column section has been created using any of these methods, the shape(s) comprising the 
section can be edited using the tools described in Chapter 4, including adding, deleting, changing 
and distributing rebar.  

3.2.1. Quick Design Wizard 

The Quick Design Wizard, shown in Figure 3.1, appears when you start CSiCol. 

The Quick Design Wizard makes creating a model quick and easy because this form provides access 
to all the other forms needed to create and analyze the model as well as to generate results. The 
general process involved in using the Quick Design Wizard is as follows: 

1. Click on the File Menu > Quick Design Wizard button to access the Quick Design 
Wizard form. The Wizard provides access to all the other forms needed to create 
and analyze the model as well as to generate results.   

2. Project Details: Click on the Define button next to Project Details to access the 
Project Information form where the details of the project such as Project Name, 
Project Code, Engineer and Company can be filled in.  

The Project Information form can be accessed later for viewing and modification 
from the Define Menu>Project>Project Details button. The information specified 
on the Project Information form displays at the start of the detailed reports 
generated for the Project File. 

3. Units and Code: Click on the Define button next to Units and Code to access the 
Options form. Review and accept the defaults on the various parameters on the 
form such as working units, design codes and number format or use the drop-down 
lists and edit boxes to specify the desired values.  

These settings can also be modified later from the drop-down lists available under 
the Options Menu. 

4. Material Properties: Click on the Define button next to Material Properties to 
access the Material Properties form. The Material Properties form has separate 
tabs for concrete and rebar materials. Review and accept the defaults or use the 
edit boxes to specify the desired values.  

The Material Properties form can also be accessed later from the Define 

Menu>Project>Materials or by clicking on the  button next to the Project 
Explorer>Materials. 
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5. Column Name: Accept the default name or modify it be typing in the edit box 
next to Column Name. 

6. Section Shape:  Select the shape type (Rectangular or Circular) to access the 
Rectangular Column or the Circular Column form and define the shape name, 
cross-section dimensions, clear cover, rebar size and rebar distribution.  

The shapes and rebars can be modified later by selecting them and editing the 
dimensions and other parameters in the Property grid. 

7. Consider Slenderness Toggle: When this toggle is turned on, CSiCol will 
consider slenderness effects and column framing will need to be defined using the 
Define Framing button. When this toggle is turned off, CSiCol will ignore 
slenderness effects, the Define Framing button will be unavailable, and you can 
skip to Step 9.  

8. Define Framing: This button is active only if slenderness effects are being 
considered. Clicking this button accesses the Column Framing Conditions form.  

This form can also be accessed later from the Define Menu>Slenderness> 

Framing Conditions or by clicking on the  button next to the Project 
Explorer>Columns>Framing>Conditions. 

9. Define Loading: Detailed or Simple Loading may be defined. If the Consider 
Slenderness toggle is turned on, CSiCol will automatically display the form for 
defining the load case in the detailed mode when the Define Loading button is 
clicked. If the Consider Slenderness toggle is turned off, CSiCol will automatically 
display the form for defining the load case in the simple mode.  

The Define Loading form can also be accessed later using Define Menu> 

Loading>Loading or by clicking on the  button next to the Project 
Explorer>Columns>Loading. 

10. Results: After the column section and its loading and framing conditions have 
been defined, the results can be viewed using the various options available under 
the Results section. Click on the Capacity Ratio button to determine if the column 
section is adequate for the loading defined. To view the detailed results, click the 
Detailed Results button. The Interaction Diagrams button can be used to access 
the PMM interaction diagrams and the Generate Report button generates a one-
page report for the defined column. All these results along with some additional 
results can be viewed from the Results Menu or from the Project Explorer>Results 
after closing the wizard. The report can be viewed from the Project 
Explorer>Report. 
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Figure 3.1 Quick Design Wizard Form 

3.2.2. Blank Model 

When the Blank Model button is used, CSiCol adds a blank working area to the current Project 
File.  

The basic procedure for creating a section using the File Menu>Blank Model is as follows: 

1. Select the File Menu>Blank Model button to add a blank working area to the 
Project file. 

2. The program will open with the default working units and design code. Use the 
drop-down lists in the Options Menu>General to change these settings, if 
necessary. 

3. Use the Define Menu>Stress Strain>Concrete button or click on the  button 
next to the Project Explorer>Stress-Strain>Concrete to access the Define Concrete 
Confinements form and define new confinement models or to modify the default 
one. 
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4. Use the Define Menu>Stress Strain>Steel button or click on the  button next to 
the Project Explorer>Stress-Strain>Steel to access the Define Steel Stress-Strain 
form and define new steel stress-strain models or to modify the default one. 

5. Use the Define Menu>Project>Materials button or the  button next to the 
Project Explorer>Materials to access the Material Properties form and define the 
concrete and rebar properties.  

6. Use one of the following tools to add a shape to the current column section: 

a. Select any of basic concrete shapes available in Draw Menu>Concrete 
Shapes to draw in the working area. 

b. Select any of basic steel shapes available in Draw Menu>Steel Shapes to 
draw in the working area. 

c. Click on the Draw Menu>Add Shapes>Shape Library button to access a 
selection list of different shapes. 

d. Click on the Draw Menu>Add Shapes>Steel Shapes button to access a 
library of standard steel shapes. 

e. Click on the Draw Menu>Add Shapes>Coordinates button to access the 
Add Points form where the coordinate values of the desired shape can 
either be entered directly or imported from external sources using the 
Import button.  

f. Click on the Draw Menu>Import Shapes>Text File button to import a 
shape from coordinates saved in a text file. 

g. Click on the Draw Menu>Import Shapes>DXF File button to import a 
shape from a DXF file. 

7. Repeat Step 6 to add more shapes into the current column. 

8. Use the buttons available on the Edit Menu such as Flip, Merge, Stack, Align and 
Edit to modify the shapes to obtain the desired section. 

9. Use the various options available in Draw Menu>Rebars to add rebars into the 
section. The rebars can be added as points, line or in rectangular or circular pattern 
as required. 

10. If necessary, click on a shape or rebar to activate the Property grid and edit their 
dimensions and other properties numerically. The Property Grid for concrete and 
steel shapes have a tab for the stress strain model where the properties of the stress 
strain model assigned to the shape can be viewed and modified, if necessary. The 
Property grid can also be accessed by selecting the shape or rebar from the Project 
Explorer under Columns view.  

Note: The dimensions of shapes created using  the Draw Menu>Concrete 
Shapes>Polygon button can only be edited by modifying the nodal coordinates 
either from the Points tab of Property grid or from Edit Menu>Edit>Edit Points. 
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The parametric shapes can be converted to polygon from Edit Menu>Edit>Edit 
Points. 

11. If the column is being designed as slender, click the Define 
Menu>Slenderness>Slenderness Effects button to enable this feature. If the 
column is not slender, skip this step and Step 12. 

12. If the column is slender, use the Define Menu>Slenderness>Framing Condition 

button or click on the  button next to the Project 
Explorer>Columns>Framing>Conditions to define the framing scenario for the 
column cross-section.  

Note: This button is activated only when slenderness effects are being considered. 

13. Use the Define Menu>Loading>Loading button or click on the  button next to 
the Project Explorer>Columns>Loading to define loads for the column cross-
section. 

14. Use the Home Menu>Design>Auto-Design button to apply an iterative process to 
determine the minimum reinforcement and the reinforcement layout for the 
governing load combination that satisfies the user-defined limits for smallest and 
largest bar sizes, clear cover, clear spacing, maximum rebar ratio and maximum 
D/C ratio.  

Note: This option is only available for rectangular and circular reinforced sections. 

15. Use the various options available under the Results Menu or the Project 
Explorer>Columns>Results to review outputs for the column cross-section. 

16. Click on the options available under the Report view of the Project Explorer to 
view the column summary, generate a one-page report or a detailed report for the 
selected column. 

3.2.3. Rectangular Model 

Use the Rectangular Model button to add a new rectangular column section to the current Project 
file. The following provides a basic approach for adding the rectangular column to the active 
Project file. 

1. Select the File Menu>Rectangular Model button to add a rectangular column to 
the Project file. 

2. The program will open with the default working units and design code. Use the 
drop-down lists in the Options Menu>General to change these settings, if 
necessary. 

3. Use the Define Menu>Stress Strain>Concrete button or click on the  button 
next to the Project Explorer>Stress-Strain>Concrete to access the Define Concrete 
Confinements form and define new confinement models or to modify the default 
one. 
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4. Use the Define Menu>Stress Strain>Steel button or click on the  button next to 
the Project Explorer>Stress-Strain>Steel to access the Define Steel Stress-Strain 
form and define new steel stress-strain models or to modify the default one. 

5. Use the Define Menu>Project>Materials button or the  button next to the 
Project Explorer>Materials to access the Material Properties form and define the 
concrete and rebar properties.  

6. If necessary, click on the shape or rebar to activate the Property grid and edit their 
dimensions and other properties numerically. The Property Grid for concrete and 
steel shapes have a tab for the stress strain model where the properties of the stress 
strain model assigned to the shape can be viewed and modified, if necessary. The 
Property grid can also be accessed by selecting the shape or rebar from the Project 
Explorer under the Columns view. 

7. If the column is being designed as slender, click the Define 
Menu>Slenderness>Slenderness Effects button to enable this feature. If the 
column is not slender, skip this step and Step 8. 

8. If the column is slender, use the Define Menu>Slenderness>Framing Condition 

button or click on the  button next to the Project 
Explorer>Columns>Framing>Conditions to define the framing scenario for the 
column cross-section.  

Note: This button is activated only when slenderness effects are being considered. 

9. Use the Define Menu>Loading>Loading button or click on the  button next to 
the Project Explorer>Columns>Loading to define loads for the column cross-
section. 

10. Use the Home Menu>Design>Auto-Design button to apply an iterative process to 
determine the minimum reinforcement and the reinforcement layout for the 
governing load combination that satisfies the user-defined limits for smallest and 
largest bar sizes, clear cover, clear spacing, maximum rebar ratio and maximum 
D/C ratio.  

Note: This option is only available for rectangular and circular reinforced sections. 

11. Use the various options available under the Results Menu or the Project 
Explorer>Columns>Results to review outputs for the column cross-section. 

12. Click on the options available under the Report view of the Project Explorer to 
view the column summary, generate a one-page report or a detailed report for the 
selected column. 
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3.2.4. Circular Model 

Use the Circular Model button to add a new circular column section to the current Project file. The 
following provides a basic approach for adding the circular column to the active Project file. 

1. Select the File Menu>Circular Model button to add a circular column to the Project 
file. 

2. The program will open with the default working units and design code. Use the 
drop-down lists in the Options Menu>General to change these settings, if 
necessary. 

3. Use the Define Menu>Stress Strain>Concrete button or click on the  button 
next to the Project Explorer>Stress-Strain>Concrete to access the Define Concrete 
Confinements form and define new confinement models or to modify the default 
one. 

4. Use the Define Menu>Stress Strain>Steel button or click on the  button next to 
the Project Explorer>Stress-Strain>Steel to access the Define Steel Stress-Strain 
form and define new steel stress-strain models or to modify the default one. 

5. Use the Define Menu>Project>Materials button or the  button next to the 
Project Explorer>Materials to access the Material Properties form and define the 
concrete and rebar properties.  

6. If necessary, click on the shape or rebar to activate the Property grid and edit their 
dimensions and other properties numerically. The Property Grid for concrete and 
steel shapes have a tab for the stress strain model where the properties of the stress 
strain model assigned to the shape can be viewed and modified, if necessary. The 
Property grid can also be accessed by selecting the shape or rebar from the Project 
Explorer under the Columns view. 

7. If the column is being designed as slender, click the Define 
Menu>Slenderness>Slenderness Effects button to enable this feature. If the 
column is not slender, skip this step and Step 8. 

8. If the column is slender, use the Define Menu>Slenderness>Framing Condition 

button or click on the  button next to the Project 
Explorer>Columns>Framing>Conditions to define the framing scenario for the 
column cross-section.  

Note: This button is activated only when slenderness effects are being considered. 

9. Use the Define Menu>Loading>Loading button or click on the  button next to 
the Project Explorer>Columns>Loading to define loads for the column cross-
section. 
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10. Use the Home Menu>Design>Auto-Design button to apply an iterative process to 
determine the minimum reinforcement and the reinforcement layout for the 
governing load combination that satisfies the user-defined limits for smallest and 
largest bar sizes, clear cover, clear spacing, maximum rebar ratio and maximum 
D/C ratio.  

Note: This option is only available for rectangular and circular reinforced sections. 

11. Use the various options available under the Results Menu or the Project 
Explorer>Columns>Results to review outputs for the column cross-section. 

12. Click on the options available under the Report view of the Project Explorer to 
view the column summary, generate a one-page report or a detailed report for the 
selected column. 

3.3. Methods for Importing Columns 
Columns can be imported from the following two sources: 

• ETABS  
• Older version of CSiCol 

3.3.1. Import ETABS Model 

The Import ETABS Model button allows the user to select an existing ETABS model and import 
the concrete columns defined in the model into CSiCol. The basic procedure for importing an 
ETABS model into CSiCol is as follows: 

1. Click on the Import ETABS Model button to access the Open ETABS Model form. 
Find and select the ETABS model file to be selected and click on the Open button. 

2.  Select the load cases or load combinations that you wish to import into CSiCol. 
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Figure 3.2: Select Load Cases/Combinations to Import 

3. Once you select the load combinations, the ETABS Model form will be accessed 
where you can view the 3D model and visually select the columns you wish to 
import. Multiple columns can be selected, and the properties of the selected 
columns can be viewed under the Properties grid. Columns can also be selected 

based on their section and story location by clicking on the  button in the 
context sensitive toolbar. 
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Figure 3.3 Importing Columns from ETABS Model 

Note: This feature will only work if ETABS is installed on the computer.  

If the file path for ETABS executable has not been set before, you will first be asked to set it. The 
column sections are imported along with their loading conditions, material assignments and 
framing conditions. The Effective Length factors (k) are not imported. By default, the working 
units will be the same as the database unit in ETABS. As of now, only US (inch) and SI (mm) unit 
systems are supported in CSiCol.  

Note: If the units setting in the ETABS file is in MKS system, it will be converted to SI (mm) unit 
system.  

If the building model has not been analyzed and designed in ETABS, only the model geometry will 
be imported. If the column is failing in ETABS, it is still possible to import the column, but the 
reinforcements will not be available. 

Important Note: The clear cover in CSiCol refers to the cover to the MAIN reinforcing bars.  Since 
ETABS defines the clear cover based on the ties / confinement bars, the tie diameter will be added 
to the clear cover when importing from ETABS into CSiCol.  

3.3.2. Import CDB File 

This button can be used to import a CDB file i.e a CSiCol file of an older version. 

Note: Multiple columns can be imported and the columns are imported along with their framing 
conditions, loadings, material assignments and slenderness properties. By default, the working 
units will be the same as that used in the older version of CSiCol. As of now, only US (inch) and 
SI (mm) unit systems are supported in this version of CSiCol. If the units in the CDB file are in any 
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other system, it will be converted to either US (inch) or SI (mm) unit system.  If the CDB file uses 
an older version of the design code available in CSiCol v10, it will open with the new version of 
the design code. 

3.4. Add Shapes from a Library 
Regardless of the method used to begin the column, shapes from the standard shape libraries can 
be added to a column section, for example, to create a complex column section. The tools available 
for merging shapes are described in Chapter 4. Add a shape from one of the standard libraries as 
follows: 

• Basic Concrete Shapes 
• Basic Steel Shapes 
• Shape Library 
• Steel Shapes 

3.4.1. Basic Concrete Shapes 

Select any of basic concrete shapes available under Draw Menu>Concrete Shapes to draw in the 
working area. There are several basic shapes available such as rectangle, box, circle and tee. Shapes 
of any arbitrary geometry can also be drawn graphically in the working area by selecting the 
Polygon shape  

3.4.2. Basic Steel Shapes 

Select any of basic steel shapes available under Draw Menu>Steel Shapes to draw in the working 
area. There are several basic shapes available such as tube, I shape, pipe, angle and tee. 

3.4.3. Shape Library 

Click on the Draw Menu>Add Shapes>Shape Library button to access a selection list of different 
shapes. The shapes available in the Shape Library include AISC Steel Shapes, BS Steel Shapes, 
CISC Steel Shapes, Basic Concrete and Steel Shapes, Box Girder Shapes, Bridge Pier Shapes, Cold 
Formed Shapes, Fillet and Chamfer, Plate Library, Rounded Steel Shapes and Shear Walls. 

3.4.4. Steel Shapes 

Select any of the standard steel shapes by clicking on the Draw Menu>Add Shapes>Steel Shapes 
button. 

3.5. Add Shape by Coordinates  
A shape can be defined by specifying its nodal point coordinates using keyboard input or by 
importing the coordinates from an external source. Those sources include comma separated, tab 
separated or spaced .txt file. 
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• Click on the Draw Menu>Add Shapes>Coordinates button to access the Add Points 
form where the coordinate values of the desired shape can either be entered directly or 
imported from external sources using the Import button. 

• Click on the Draw Menu>Import Shapes>Text File button to import a shape from 
coordinates saved in a text file. 

3.6. Add Shape by Importing .DXF File  
A shape can be imported from a .DXF file created using AUTOCAD. 

• Click on the Draw Menu>Import Shapes>DXF File button to import a shape from a 
DXF file. 

Note: This feature can only be used for importing shapes. Rebar layouts cannot be imported using 
.DXF File. 

3.7. Export Shapes 
The Export Section as DXF File button under Draw Menu>Export allows the user to save the 
selected shape as a DXF file which can be opened using AutoCAD. 

3.8. Add Rebars 
Rebars can be added to the section in different patterns as required using the buttons available under 
Draw Menu>Rebars. 

• Point: Use this button to draw a single rebar in the working area with a mouse click at 
the desired location. 

•  Line: Use this button to draw a single line of rebar in the working area. 
•  Rectangle: Click on this button to draw rebar in a rectangular pattern. 
• Circle: Click on this button to draw rebar in a circular pattern. 

Important Note:  

• The number of rebar in the pattern, clear cover, and minimum clear spacing can be modified 
using the Property grid (Figure 3.4) which is activated in the context sensitive area by selecting 
the rebar either by clicking on it in the working area or selecting it from the Project 
Explorer>Columns>Rebar Patterns. 

• The clear cover in CSiCol is defined based on the clear cover to the MAIN reinforcement bars, 
not the ties / confinement bars.  

• Base Rebar Pattern – This assignment is required for the calculation of Magnified Moments.  
o By default, the first rebar/ rebar layout drawn will be set as the “Base Rebar Pattern” 

under General Tab in property grid.  
o This field is allowed to toggle only when there are two or more rebar/ rebar layouts 

drawn in the canvas.  
o Assigning a rebar/ rebar layout as the Base Rebar Pattern will automatically remove 

the Base Rebar Pattern assignment from the previous rebar/ rebar layout.  
o When the rebar/rebar layout that is currently set as the Base Rebar Pattern is deleted, 

the first rebar/ rebar layout from the order drawn is set as the Base Rebar Pattern.  
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Figure 3.4 Property grid for rebars 

3.9. Add Columns to Project File 
Use the Define Menu>Project>Columns button or the  button besides Project 
Explorer>Columns to access the Define Column form where new columns can be added to the 
Project file and existing ones can be renamed or removed. The columns in the Project File can be 
viewed and modified by selecting the desired column from the Project Explorer>Columns. 

3.10. Create Composite Columns 
Composite columns can be created by simply placing the shapes of different materials one over the 
other in the desired way. It is not necessary to create holes before placing shapes over one another 
since CSiCol already accounts for the overlapped area. The procedure to move shapes to a desired 
location has been explained in Chapter 4. 

Note: For composite sections, concrete is considered as the base material and the transformed 
section properties are reported in the Results. 

3.11. Materials, Stress Strain Models and Confinement Models 

3.11.1. Define Material Properties 

Use the Define Menu>Project>Materials button to access the Define Materials form (Figure 3.5) 
where existing materials can be viewed or modified, and new materials can be added from the 
Material Library. A list of existing materials is displayed under the Materials section and the 
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properties of the selected material is displayed under the Material Properties section. The 
properties can be modified by directly typing in the desired values into the edit boxes provided. 
New materials can be added using the Material Library form which can be accessed by clicking on 

the  button. The Material Library form provides a selection of concrete, rebar and steel 
materials from several material libraries such as USA, China and Europe.  

 

Figure 3.5 Define Materials Form 

Note: The properties of existing materials can also be modified by selecting them from the Project 
Explorer under the Materials view. The Define Materials form can also be accessed by clicking on 

the  button besides Project Explorer>Materials. 

3.11.2. Define Confinement Models and Stress Strain Models  

The buttons available under Define Menu>Stress Strain allow the user to define the stress strain 
models for concrete and steel. 

• Concrete button: Click on this button to access the Define Concrete Confinements form 
where existing confinement models can be viewed or modified, and new confinement 
models can be added. A list of existing confinement models is displayed under the 
Confinement Models section and the properties of the selected confinement model is 
displayed under the Properties section. The properties can be modified by directly 
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typing in the desired values into the edit boxes provided.  
New confinement models can be added using the Add Confinement Model form which 
can be accessed by clicking on the  button. The Add Confinement Model form 
provides a selection of confinement models. The Define Concrete Confinement form 

can also be accessed by clicking on the  button next to the Project Explorer>Stress-
Strain>Concrete. 
 

• Steel button: Click on this button to access the Define Steel Stress-Strains form where 
existing stress-strain models can be viewed or modified, and new stress-strain models 
can be added. A list of existing stress-strain models is displayed under the Stress-Strain 
Models section and the properties of the selected stress-strain model is displayed under 
the Properties section. The properties can be modified by directly typing in the desired 
values into the edit boxes provided.  
New stress-strain models can be added using the Add Stress-Strain Model form which 
can be accessed by clicking on the  button. The Add Stress-Strain Model form 
provides a selection of stress-strain models. The Define Steel Stress-Strain form can 

also be accessed by clicking on the  button next to the Project Explorer>Stress-
Strain>Steel. 

Note: The properties of existing concrete confinement models or steel stress-strain models can also 
be modified by selecting them from the Project Explorer under the Stress Strain view. 

The default concrete model is the Mander’s Unconfined Model. The default model for rebar is the 
Park Strain Hardening Model.  

The stress-strain model for concrete and steel are assigned to the shape. The stress-strain model 
used for a concrete or steel shape can be changed by choosing the desired stress-strain model from 
the Stress Strain Curve drop down list in the General tab of the Property grid. The properties of the 
stress-strain model assigned to the shape can be modified under the Stress-Strain tab of the Property 
grid. The Property grid can be activated by selecting the desired shape either by clicking on it in 
the working area or selecting it from the Project Explorer under the Columns view.  

The stress-strain model for rebar is assigned to the rebar material. The stress-strain model used for 
the rebar can be changed from the Stress-Strain Curve drop down list of the Material Properties 
grid. The properties of the stress strain model assigned to the rebar material can be modified under 
the Stress-Strain tab of the Material Properties grid. The Material Properties grid can be activated 
by selecting the desired material from the Project Explorer under Materials view. 

Important Note: The properties assigned to the materials will be used for capacity calculation 
while the properties assigned to the stress strain models or confinement models will be used for 
moment-curvature calculation. By default, these two values will be the same i.e. every 
concrete/steel shape will have a corresponding stress-strain model and every rebar material will 
have a corresponding stress strain model. However, the user may manually change the material 
properties assigned to the stress strain model to be different from that assigned to the shape or 
material without affecting the capacity results. This is allowed because the user may wish to 
calculate the moment-curvature based on strength higher than the design strength of the material. 
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3.11.3. Define the Base Shape/Rebar Pattern 

This assignment is required for the calculation of Magnified Moments. The equation for calculating 
the effective stiffness in ACI-318 assumes a section with a single type of concrete material, a single 
type of rebar material and a single type of steel material as seen in Equations (3.1) and (3.2). But, 
for a column using different types of concrete, rebar and steel materials in the same section we need 
to obtain equivalent Ig, equivalent Ise and equivalent Isx for concrete, rebar and steel respectively. 
In order to get these separate transformed sections, we need to define 3 separate base materials for 
concrete, rebar and steel. 

(𝐸𝐸𝐸𝐸)𝑒𝑒𝑒𝑒𝑒𝑒 =
(0.2𝐸𝐸𝑐𝑐𝐼𝐼𝑔𝑔 + 𝐸𝐸𝑠𝑠𝐼𝐼𝑠𝑠𝑠𝑠)

1 + 𝛽𝛽𝑑𝑑𝑑𝑑𝑑𝑑
 

 

(3.1) 

(𝐸𝐸𝐸𝐸)𝑒𝑒𝑒𝑒𝑒𝑒 =
(0.2𝐸𝐸𝑐𝑐𝐼𝐼𝑔𝑔)
1 + 𝛽𝛽𝑑𝑑𝑑𝑑𝑑𝑑

+ 𝐸𝐸𝑠𝑠𝐼𝐼𝑠𝑠𝑠𝑠 

 

(3.2) 

• Base Concrete Shape: 

o By default, the first shape drawn will be set as the “Base Concrete Shape” 
under General Tab in Property grid.  

o This field may be toggled only when there are two or more concrete shapes 
drawn in the canvas.  

o Assigning a concrete shape as the Base Concrete Shape will automatically 
remove the Base Concrete Shape assignment from the previous concrete shape.  

o When the concrete shape that is currently set as the Base Concrete Shape is 
deleted, the first concrete shape from the order drawn is set as the Base 
Concrete Shape.  

• Base Rebar Pattern –  

o By default, the first rebar/ rebar layout drawn will be set as the “Base Rebar 
Pattern” under General Tab in Property grid.  

o This field may be toggled only when there are two or more rebar/ rebar layouts 
drawn in the canvas.  

o Assigning a rebar/ rebar layout as the Base Rebar Pattern will automatically 
remove the Base Rebar Pattern assignment from the previous rebar/ rebar 
layout.  

o When the rebar/rebar layout that is currently set as the Base Rebar Pattern is 
deleted, the first rebar/ rebar layout from the order drawn is set as the Base 
Rebar Pattern.  
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• Base Steel Shape  

o By default, the first steel shape drawn will be set as the “Base Steel Shape” 
under General Tab in Property grid.  

o This field may be toggled only when there are two or more steel shapes drawn 
in the canvas.  

o Assigning a steel shape as the Base Steel Pattern will automatically remove the 
Base Steel Shape assignment from the previous steel shape.  

o When the steel shape that is currently set as the Base Steel Shape is deleted, 
the first steel shape from the order drawn is set as the Base Steel Shape.  

3.11.4. Assign Materials 

Materials can be assigned to the shapes and rebars by selecting the desired material from the 
Materials drop-down list in the Property grid (Figure 3.4). The Property grid gets activated by 
selecting the shapes or rebar either by clicking on it in the working area or by selecting it from the 
Project Explorer under Columns view. 

3.11.5. Assign Confinement Models and Stress Strain Model 

For concrete and steel shapes, the stress-strain models are assigned to the shape. The stress strain 
model can be assigned by selecting the desired stress strain model from the Stress-Strain Curve 
drop-down list in the General tab of the Property grid (Figure 3.6a). The properties of the stress-
strain model assigned to the shape can be modified under the Stress-Stain tab of the Property grid. 
The Property grid gets activated by selecting the shapes or rebar either by clicking on it in the 
working area or by selecting it from the Project Explorer under Columns view. 

For rebars, the stress strain model can only be assigned to the material. Click on the Define 
Menu>Project>Materials button to access the Define Materials form (Figure 3.5) or alternatively, 
select the desired rebar material from the Project Explorer under Materials view to activate the 
Material Properties grid (Figure 3.6b) in the context-sensitive area. Change the stress-strain model 
assigned to the rebar material by selecting the desired stress strain model from the Stress-Strain 
Curve drop-down list. The properties of the stress-strain model assigned to the rebar material can 
be modified under the Stress-Strain tab of the Material Properties grid. 



User’s Manual and Technical Reference Designing Columns  

Create Confinement Zones 31 

 

 

 

 

a)  b) 

Figure 3.6  a)Property Grid for Concrete Shape b) Material Properties Grid for Rebar 
Material 

Important Note: The properties assigned to the materials will be used for capacity calculation 
while the properties assigned to the stress strain models or confinement models will be used for 
moment-curvature calculation. By default, these two values will be the same i.e. every 
concrete/steel shape will have a corresponding stress-strain model and every rebar material will 
have a corresponding stress strain model. However, the user may manually change the material 
properties assigned to the stress strain model to be different from that assigned to the shape or 
material without affecting the capacity results. This is allowed because the user may wish to 
calculate the moment-curvature based on strength higher than the design strength of the material. 

3.12. Create Confinement Zones 
Confinement zones can be created in two ways: 

• Auto Create Confinement 
• Draw Confinement  

3.12.1. Auto Create Confinement 

In this method, a confinement zone is created by the software automatically. The basic procedure 
for auto creating confinement is as follows: 

1. Select the desired column section from the Project Explorer. 
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Note: This feature is available for sections with only one rebar pattern (rectangular or circular 
patterns only). 

2. Click on the Home Menu>Design>Auto Confinement button to create a 
confinement zone in the section.  

3. By default, the confinement zone will enclose the outer perimeter of rebars. Accept 
the default or change the dimensions of the confinement zone by typing in the edit 
boxes available under the General Tab of the Property Grid. The Property Grid is 
activated in the context-sensitive area by selecting the confinement zone from the 
working area or from the Project Explorer under Confinement Zones.  

4. By default, the Mander’s Confined model is assigned to the confinement zone. 
This can be changed from the Stress-Strain Curve drop down list in the General 
Tab of the Property Grid. New confinement models must first be defined from the 
Define Concrete Confinements form which can be accessed from the Define 

Menu>Stress Strain>Concrete button or by clicking on the  button next to the 
Project Explorer>Stress-Strain>Concrete. 

5. Once the appropriate confinement model has been assigned to the confinement 
zone, select the Stress Strain Tab of the Property Grid. Review the values of the 
parameters of the confinement model such as tie diameter and tie spacing under 
the Ties heading and modify them by typing in the edit boxes available as required. 
The total main steel area will be computed from the number of rebars provided. 
But the value may be changed manually by the user, if required.  

6. Review the material properties under the Materials heading in the Stress-Strain 
Tab of the Property Grid. By default, the material properties will be the same as 
that of the material assigned to the main section. Modify the values if necessary, 
by typing in the edit boxes available. 

Note: The properties assigned to the materials will be used for capacity calculation 
while the properties assigned to the stress strain models or confinement models will be 
used for moment-curvature calculation. By default, these two values will be the same 
i.e. every concrete/steel shape will have a corresponding stress-strain model and every 
rebar material will have a corresponding stress strain model.  

However, the user may manually change the material properties assigned to the stress 
strain model to be different from that assigned to the shape or material without 
affecting the capacity results. This is allowed because the user may wish to calculate 
the moment-curvature based on strength higher than the design strength of the material. 

For auto confinement zones, the material properties will be connected to the material 
properties assigned to the main section. The total main steel area will also be computed 
automatically by the software. But both these parameters may be changed by the user, 
if required. 
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Also, when the material of the section is changed after creating the auto confinement, 
the user will be prompted to decide whether to update the material properties assigned 
to the stress strain model or not. 

3.12.2. Draw Confinement 

In this method, CSiCol allows the user to draw their own confinement zones. The basic procedure 
for drawing confinement zones is as follows: 

1. Select the desired column section from the Project Explorer. 

2. Click on the Draw Menu>Confinement>Rectangle or Circle button and draw a 
confinement zone on the section with the mouse.  

Note: Only rectangular and circular confinement zones are available. 

3. The dimensions of the confinement zone can be changed by typing in the edit boxes 
available under the General Tab of the Property Grid of the confinement zone. 
The Property Grid is activated in the context-sensitive area by selecting the 
confinement zone from the working area or from the Project Explorer under 
Confinement Zones.  

4. The confinement zone can be moved to a desired location in the same way as any 
other shape. 

5. By default, the Mander’s Confined model is assigned to the confinement zone. 
This can be changed from the Stress-Strain Curve drop down list in the General 
Tab of the Property Grid. New confinement models must first be defined from the 
Define Concrete Confinements form which can be accessed from the Define 

Menu>Stress Strain>Concrete button or by clicking on the  button next to the 
Project Explorer>Stress-Strain>Concrete. 

6. Once the appropriate confinement model has been assigned to the confinement 
zone, select the Stress Strain Tab of the Property Grid. Review the values of the 
parameters of the confinement model such as tie diameter, tie spacing and total 
main steel under the Ties heading and modify them by typing in the edit boxes 
available as required.  

7. Review the material properties under the Materials heading in the Stress-Strain 
Tab of the Property Grid. 

Note: For manually drawn confinement zones, the material properties will not be 
connected to the material properties assigned to the main section. The total main steel area 
will also need to be computed manually by the user. 

Operations such as merging, subtracting, aligning, and stacking can be performed on confinement 
zones in the same way as for other shapes to obtain complex confinement zones. Merging is only 
allowed for confinement zones with the same material properties and same confinement models 
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(rectangular confinement model or circular confinement model). After merging, the user must 
verify the dimensions in the Stress Strain tab of the confinement zone and modify them as required. 

3.13. Consider Slenderness Effects 
Toggle the Define Menu>Slenderness>Slenderness Effects button to specify whether the 
slenderness effects for the current column are to be considered or not. If slenderness effects are to 
be considered, the Framing Condition also needs to be specified. The framing condition is used to 
compute the effective length factor as well as other factors related to the moment magnification 
depending on the design codes. 

The following design codes are supported for slender columns: 

• ACI 318-08 
• ACI 318-11 
• ACI 318-14 
• IS 456:2000 
• CSA A23-3-04 
• BS 8110-97 
• Euro Code 2: 2004 

3.13.1. Specify Column Framing Conditions 

Use the Define Menu>Slenderness>Framing Conditions button when the Slenderness Effects 
toggle is turned on to access the Column Framing Conditions form and specify the information 
needed to compute the magnified moments while considering slenderness effects. In this form, 
click on the framing condition that best represents the column end/support condition (e.g. Fixed on 
both, Fix-Pin, Fix-Roller, Fix-Free, Pin-Roller and lowest story framed columns with pinned base, 
fixed base or intermediate story columns connected to frame elements on both ends). Figure 3.7 
illustrates the Column Framing Conditions relative to the XZ and YZ planes for a general case of 
Framed Columns. 
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Figure 3.7 Column Framing Conditions 

After selecting the framing condition, the framing conditions in XZ plane is displayed in the 
working area as seen in Figure 3.8. The framing condition can be viewed either in 2D (either XZ 
or YZ plane) or 3D by selecting the desired option in the context-sensitive toolbar. 

• XZ/YZ or 3D buttons: Click on the XZ or YZ button to view and change the framing 
parameters in the XZ or YZ planes respectively. Click on the 3D button to view the 
framing in 3D. 

• Zoom In button: Click the Zoom In button to zoom in (make the image larger). 
Zooming in can also be done by moving the scroll button on the mouse upwards. 

• Zoom Out button: Click the Zoom Out button to zoom out (make the image smaller). 
Zooming out can also be done by moving the scroll button on the mouse downwards. 

• Rest and Refresh View button: Use this button to restore the original default display of 
the interaction surface. 
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Figure 3.8 Framing Conditions View, 2D 

3.13.2. Effective Length Factor 

Use the following procedure to calculate the effective length factors: 

1. Click on the Define Menu>Slenderness>Show Framing button to view the framing 
conditions. 

2. For each plane (XZ or YZ), the Framing grid (Figure 3.9) gets activated in the 
context-sensitive area where the framing parameters such as unsupported length of 
column, c/c length of columns and length of beams need to be entered. 

Note: By default, Eurocode 2:2004 does not consider the contribution of the 
stiffness of the top and bottom columns to the joint stiffness. So, for Eurocode, an 
additional “Consider Non-failing Columns” toggle has been introduced in the 
Framing grid to override this. This toggle allows the user to consider the 
contribution of ‘non-failing’ columns to the joint stiffness, if desired.  

For BS 8110-97 code, there is an additional option to consider the beams framing 
into the column to be simply supported. Turn on the “Simply Supported, Top” or 
“Simply Supported, Bottom” toggles to consider simply supported beams framing 
the column at the top and bottom nodes, respectively. 

3. Select each of the connected beams and columns to activate the Frame Member 
grid where you can view the properties of the section assigned to them and change 
them, if necessary. By default, the connected beams and columns are assigned a 
program defined beam and column framing section respectively. If you want to 
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define your own sections or change the dimensions and other properties of the 
existing ones go to the next step. If not, skip to step 7. 

4. Click on the Define Menu>Slenderness>Framing Sections button or the  button 
next to the Project Explorer>Columns>Framing>Sections to access the Define 
Framing Sections form where a list of existing framing sections is displayed. Using 
this form, new framing sections can be added, and existing ones renamed or 
removed. 

5.  Select the desired framing section from the Project 
Explorer>Columns>Framing>Sections. The selected section will be displayed in 
the working area and the Property grid will get activated in the context-sensitive 
area. Change the dimensions and other properties of the selected framing section 
as required using the Property grid. 

6. After defining new sections and modifying the properties of the sections as 
required, click on the Define Menu>Slenderness>Show Framing button to view 
the framing condition.  

7. Select the connecting beam or column whose section you would like to change. 
The Frame Member grid gets activated. Select the desired section under the Section 
drop down list.  

8. Once the parameters have been correctly entered and sections have been correctly 
assigned, click on the Compute button in the Framing grid to calculate the 
Effective Length (k) factors.  

9. Perform the above steps for both XZ and YZ planes. Alternatively, the effective 
length values can be specified through direct input.  

Note: The Framing Condition, Framing Sections and Show Framing buttons are 
activated only when the Slenderness Effects toggle is turned on. 

The framing view and Framing grid can also be accessed from the Project Explorer 
under Columns>Framing>Conditions. 
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Figure 3.9 Framing Grid 

3.14. Specify Column Loads 
The two modes to define loads on the column are the simple mode and the detailed mode. Column 
loads can be defined in the simple mode if the column being considered is a short column (no 
slenderness considered); otherwise, the detailed mode should be used. CSiCol automatically opens 
the Loading form in either the detailed mode or the simple mode depending on whether the 
Slenderness Effects toggle is turned on or off. 

 Figure 3.10 illustrates loading on the column and cross-section. Unlimited load combinations may 
be defined for a column cross-section by clicking on the Define Menu>Loading button. 

Note: Sign Convention used by the software:  
Axial Load:  
For Axial Load, compression is considered to be positive and tension is considered to be 
negative. 

Bending Moment: 
Similar to ETABS, for columns bending in double curvature, the top and bottom end 
bending moments are of opposite signs and for columns bending in single curvature, the 
top and bottom end bending moments are of the same sign 
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Figure 3.10 Column Loading on Column and Cross-Section 

3.14.1. Simple Loading Mode 
Simple loads apply when (a) the column is to be designed as a short column or when slenderness 
effects can be ignored; (b) the loads and bending moments have already been magnified by separate 
analysis, such as the P-Delta analysis option in ETABS or by other procedures; and (c) detailed 
loading or column framing information is not available. 

For the simple load combination case, the combination name, axial load value (Pu), top and bottom 
bending moments about X-axis (Mux) and about Y-axis (Muy) must be specified. Define the simple 
loading on the column as follows: 

1. Specify the load combination name, axial load and the bending moments. 

2. Specify as many load combinations as required for analysis and design. 

3. Import load combinations from previously saved text files using the Import button.  

3.14.2. Detailed Loading Mode for Slender Columns 

Detailed load combinations can be defined along X and Y, separately. The moments under Along 
X and Along Y tabs correspond to the moments about the X-axis and about the Y- axis respectively. 
Detailed loads are needed only if slenderness effects need to be considered. Define a detailed load 
combination as follows: 

1. Select the loading direction (Along X or Along Y) by clicking on the respective tab, and 
then specify the combination name. 

2. Specify the following code-dependent parameters: 

x x Mx/ M3 

My/ M2 

Y 

Y 

2 

3 
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For the ACI-318 Design Code: 

• Specify the axial load, non-sway top and bottom bending moment in the spreadsheet 
cells.  

• Click on the Check button under the Check Sway column to access the Sway Conditions 
form. There are 3 methods available for sway check: Stability Index, Second order 
Analysis and Relative Stiffness of Bracing to Columns. Select the desired method for 
sway check and fill in the required parameters. Click on the Check Sway button to 
check for sway condition. Click on OK once done. 

•  If the column is found to be of sway type, the Consider Sway toggle in the Define 
Loading Slenderness form will be automatically turned on. If the column is found to 
be of non-sway type, the software can still be forced to consider it as a sway frame by 
manually turning on the Consider Sway toggle.  

• When the Consider Sway toggle is turned on, the input fields for the values of the sway 
parts of axial load, top and bottom bending moments, Story Load, Story Shear, Relative 
Sway, Critical Load and Stability Index will get activated. Edit the values as and if 
required. These values will be used to calculate the magnified moments. 

For the IS 456-2000 Design Code: 

• Specify the axial load, bottom bending moment, and top bending moment values.  
• Click on the Check button under the Check Sway column to access the Sway Conditions 

form. There are 3 methods available for sway check: Stability Index, Second order 
Analysis and Relative Stiffness of Bracing to Columns. Click on the Check Sway 
button to check for sway condition. Click on OK once done. 

•  If the column is found to be of sway type, the Consider Sway toggle in the Define 
Loading Slenderness form will be automatically turned on. If the column is found to 
be of non-sway type, the software can still be forced to consider it as a sway frame by 
manually turning on the Consider Sway toggle.   

For the CSA A23-3-04 Design Code: 

The process for defining detailed loads for CSA Design Code is the same as that for 
ACI Design Code. 

For the Euro Code 2:2004 Design Code: 

• Specify the axial load, top moment and bottom moment values. By default, the column 
is considered to be braced in the selected direction. Turn on the Consider Unbraced 
toggle to change this default assumption.  

Note: For Eurocode 2, moment magnification is not considered for composite sections 
(i.e. the steel area coming from the steel shape in the composite section will not be 
considered. Only the rebar area will be considered) 

The parameters required for the calculation of magnified moments in Eurocode2 such 
as concrete partial safety factor (γc), reinforcing partial safety factor (γs), long term 
compressive strength factor (αcc) can be specified in the Options Menu>Partial Safety 
Factors tab and ambient relative humidity (RH%) and ratio SLS to ULS moments (rm) 
can be specified in the Options Menu>Design Parameters tab. Long term compressive 
strength factor (αcc) , long term tensile strength factor (αct), ambient relative humidity 
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(RH%) and ratio SLS to ULS moments (rm) can be specified in the Options 
Menu>Slenderness Parameters tab. 

For the BS8110-97 Design Code: 

• Specify the axial load, top moment, and bottom moment values. By default, the column 
is considered to be braced in the selected direction. Check the Consider as Un-braced 
toggle to change this default assumption.  

3. Click the  button to add a new load combination. 

4. Edit the existing load combinations by directly typing in the edit boxes. 

Note: The final design loads after the moment magnification can be viewed from Results 
Menu>Capacity>Design Loads or from the Project Explorer under Results>Capacity> 
Design Loads. 

3.14.3. Sway Check (Based on ACI 318-14) 

Click on the Check button under the “Check Sway” Column of the Define Loading Slenderness 
form to access the Sway Conditions form. The Sway Conditions form is shown in Figure 3.11. The 
sway check can be performed based on the following three methods: 

• Stability Index: This check is performed for the entire story. If the Stability Index (Q) 
of a story is less than or equal to 0.05, the story is assumed to be non-sway. The data 
required to perform this check includes the Story Load, Story Shear, Relative Lateral 
Deflection and c/c length of column. If the column is found to be of sway type, the 
parameters entered in this form gets transferred to the sway part of the Loading form 
and can be edited, if necessary. 

• Second Order Analysis: If the increase in the end moments of a column caused by 
second-order effects does not exceed 5% of the first-order end moments, the column 
in the structure will be considered to be non-sway. The input required is the end 
moments for the first and second-order analysis results. The program reports the 
percentage difference for both end moments obtained by the first and second-order 
analyses.  

• Relative Stiffness of Bracing to Columns: A column is assumed to be non-sway if it 
is located in a story in which the bracing elements (shear walls, shear trusses, and other 
types of lateral bracing) have such substantial lateral stiffness as compared to the lateral 
stiffness of the column (greater than or equal to 12), so that any resulting lateral 
deflection is too small to affect the column strength substantially. The input required 
is the sum of lateral stiffness of all elements bracing the column and the lateral stiffness 
of the column itself.  
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Figure 3.11 Sway Conditions form 

3.15. Column Auto Design 
The Home Menu>Design>Auto Design feature is a very effective, efficient and powerful tool for 
the design of column reinforcement with or without considering slenderness effects. Use the 
Column Auto Design feature to design the column reinforcement in accordance with the various 
design parameters defined/specified by the user.   

The Auto Design tool in CSiCol uses an iterative process to identify the minimum reinforcement 
and the reinforcement layout that can be provided to the selected column to satisfy the user-
specified maximum capacity ratio limit for the governing load combination (load combination 
which gives the highest D/C ratio). The basic procedure for using this tool is as follows: 

1. Select the desired column from the Project Explorer. 

Note:  

• This feature is only available for rectangular and circular reinforced concrete 
columns with only one rectangular or circular rebar pattern. 

• This option is available for rectangular and circular reinforced concrete 
columns with only one rectangular or circular rebar pattern imported from 
ETABS. 

• When columns are imported from CDB files, they are imported as polygons. 
So, this feature is not available for columns imported from CDB files. 
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2. Click on the Auto Design button to access the Design form (Figure 3.12). 

3. Accept the default settings for the rebar selection or change them by using the 
drop-down menus, edit boxes and toggles provided, if necessary. The settings that 
are available are as follows: 

a. Smallest Bar: Use this edit box to specify the smallest rebar that can be 
used for the design. 

b. Largest Bar: Use this edit box to specify the largest rebar that can be used 
for the design. 

c. Clear Cover: Use this edit box to specify the clear cover that must be 
provided in the section. 

d. Clear Spacing: Use this edit box to specify the minimum clear spacing 
between the rebars. 

e. Maximum Rebar Ratio: Use this edit box to specify the maximum rebar 
ratio. 

f. Maximum D/C Ratio: Use this edit box to specify the desired maximum 
D/C ratio that must be satisfied by the design. 

g. Follow Provided Layout: When this toggle is turned on, the rebar layout 
remains fixed and Auto Design only increases the bar size to satisfy the 
maximum D/C ratio limit. When this toggle is turned off, Auto Design 
increases the number of bars while satisfying the clear spacing.  

h. Allow Bundled Bars: When it is turned on, Auto Design allows bundled 
bars if the maximum D/C ratio limit cannot be satisfied using single bars. 
When this toggle is turned off, bundled bars are not allowed. 

i. Status: This shows the status of the design process. If the design has not 
been run yet, it displays “Run Design”. If the design process has been 
completed successfully, it displays “Success “and if the specified D/C 
ratio limit cannot be satisfied with the current settings of rebar selection, 
it displays “Failed”. 

4. Click on the Run button to start the auto design process. 

5. CSiCol displays the design information for each iteration, including the current 
rebar layout, load combination, rebar ratio and current capacity ratio. The 
information may change depending on the selections made on the Rebar Selection 
settings. CSiCol displays a “Success” status when the design process has been 
completed successfully and a “Failed” status when the maximum D/C ratio limit 
cannot be satisfied with the current settings of rebar selection for the given column 
section and load combination. Update the settings for the rebar selection and repeat 
the design process until the “Success” status is displayed. 
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Figure 3.12 CSiCol Auto Design  
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 Editing Column Cross Sections 

This chapter describes how to use the various tools available in CSiCol to edit shapes and add, edit 
and distribute rebar in a section. 

4.1. Types of Shapes 
After adding a shape, its dimensions and properties can be modified. However, the process is 
different for different types of shapes. There are basically two types of shapes based on how they 
are created: 

• Parametric Shapes: This type includes the rebar shape patterns, basic steel/concrete 
shapes defined parametrically, and the standard steel shapes obtained from the 
database. In this type of shapes, the user adds the shape using the Quick Design Wizard, 
the File Menu>Rectangular Model or File Menu>Circular Model button or selects 
the shapes from one of the available shape libraries, adding it to the current section 
(except the Polygon shape). 

Note: The parametric shapes can also be converted to polygon (non-parametric shape) 
using Edit Menu>Edit>Edit Points button which allows you to add, remove or modify 
nodal point coordinates of the selected shape. 

• Non Parametric Shapes: This type of shapes are created in several ways: by drawing 
on the screen using the Draw Menu>Concrete Shapes>Polygon button, by modifying 
the library based shapes by either flipping the shapes, merging more than one shape, 
creating holes or performing other operations to achieve the desired shape and by 
inputting the coordinates of the shape. 

4.2. Editing Parametric Shapes 
The dimensions and position of parametric shapes can be modified from the Property grid. The 
Property grid gets activated in the context-sensitive area when you select a shape either by clicking 
on it in the working area or selecting it from the Project Explorer under the Columns view. Figure 
4.1 shows the Property grid for parametric shapes. 
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Figure 4.1 Property grid for Parametric Shapes 

The parametric shapes can also be edited using Edit Menu>Edit>Edit Points button which allows 
you to add, remove or modify nodal point coordinates of the selected shape. However, editing a 
parametric shape in this way will require you to convert the parametric shape to a polygon (non-
parametric).  

4.3. Editing Non-Parametric Shapes 
The dimensions of non-parametric shapes can be edited by using the Edit Menu>Edit>Edit Points 
button which allows you to add, remove or modify nodal point coordinates of the selected shape. 
The dimensions of the shape and the holes can also be edited from the Property grid under the 
Points and Holes tab respectively as seen in Figure 4.2. The Property grid gets activated in the 
context-sensitive area when you select a shape either by clicking on it in the working area or 
selecting it from the Project Explorer under the Columns view. 
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Figure 4.2 Property Grid for Non-Parametric Shapes 

4.4. Align Shapes Graphically 
In graphical alignment, no text or numeric input is required from the user. Align shapes graphically 
as follows: 

1. Select the shapes to be aligned  

2. Choose the appropriate alignment button from the following options 

• Align Left button: Use this button to align the selected shapes along their left edge. The 
alignment is done with respect to the lowest value of x-coordinate of all the selected 
shapes. 

•  Align Right button: Use this button to align the selected shapes along their right edge. 
The alignment is done with respect to the highest value of the x-coordinate of all the 
selected shapes. 

• Align Center button: Use this button to align the selected shapes along the vertical 
centerline. The alignment is done with respect to the x-centroid of all the selected 
shapes. 

•  Align Top button: Use this button to align the selected shapes along their top edge. 
The alignment is done with respect to the highest value of the y-coordinate of all the 
selected shapes. 

•  Align Bottom button: Use this button to align the selected shapes along their bottom 
edge. The alignment is done with respect to the lowest value of the y-coordinate of all 
the selected shapes. 

•  Align Middle button: Use this button to align the selected shapes along the horizontal 
centerline. The alignment is done with respect to the y-centroid of all the selected 
shapes. 

4.5. Flip Shapes 
CSiCol has options for flipping the shapes. Select the shape to be flipped and click on the 
appropriate button on Edit Menu>Flip: 

• Flip Horizontal button: This button flips the selected shape about the vertical axis 
(mirror). 

•  Flip Vertical button: This button flips the selected shape about the horizontal axis 
(mirror). 

Note: The shapes are converted into an editable polygon after flipping. 

4.6. Stack Shapes 
Stacking is performed based on the relative location of the shapes. Select the shapes to be stacked 
and choose the appropriate stack button: 

• Stack Horizontal button: Use this button to stack the selected shapes horizontally, side 
by side. The y-coordinates of the shapes do not change. 

• Stack Vertical button: Use this button to stack the selected shapes vertically, one on 
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top of the other. The x-coordinates of the shapes do not change. 

4.7. Merge Shapes 
Two shapes with the same material properties and have a common edge or that overlap can be 
merged. Merge shapes as follows: 

1. Select the shapes to be merged. 

2. Click on the Edit Menu>Merge button. 

3. Verify the final shape after merging. 

Note: The shapes are converted into an editable polygon after merging. 

4.8. Create Holes in Shapes 
Use the following procedure to create a hole in a shape or section: 

1. Create the shape or the section to which you want to add a hole (first shape or 
section).  

2. Add a shape whose shape and size are the same as that of the desired hole (second 
shape).  

3. Move the second shape to the place where the hole is to be created.  

4. Select both the shapes and click on the Edit Menu>Merge>Subtract button. 

Note: The shapes are converted into an editable polygon after creating holes. The dimensions 
of the hole can be modified from the Property grid under the Holes tab. 

4.9. Move Shapes 
Selected shapes in the working area can be moved either using the mouse or by displacement values 
from the Edit Menu>Edit>Move Sections button.  

Move the shapes using the mouse as follows:  

1. Click on the Edit Menu>Select button to activate the Selection Mode. 

2. Select a single shape to be moved or multiple shapes by holding the Ctrl or Shift key. 

3. Hold down the left mouse button and drag the mouse to move the shapes to the desired 
location.  

Move the shapes by displacement value as follows:  

1. Click on the Edit Menu>Select button to activate the Selection Mode. 

2. Select the shape(s) to be moved. 

3. Click on the Edit Menu>Edit>Move Sections button to access the Move Points form. 

4. Type in the displacement values in X(dx) and Y direction (dy) on the form. 
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 Obtain and Interpret Results 

This chapter briefly describes the different results generated by CSiCol.  

5.1. Overview 
In this chapter, it has been assumed that the user is familiar with the basic concepts of column 
design and analysis, structural concrete mechanics (especially the structural interpretation of the 
design parameters) and structural analysis results. The main topics presented in this chapter address 
the following:   

• Display geometric properties and other results  
• Plot the flexural stresses resulting from various load combinations  
• Generate interaction curves and surfaces.  
• Plot moment-curvature curves 
• Check the adequacy or capacity of a column section for different load combinations  

5.2. Section Properties 
To view a summary of the overall dimensions and geometric properties of the current column 
section in the working area, use the Results Menu> Section> Section Properties button or the 
Project Explorer>Columns>Results> Section> Section Properties to access the Section Properties 
form. This form is divided into 3 sections: 

• Basic Properties: Includes the area, shear areas, moment of inertia and torsional 
constant of the selected section. 

• Section Bounds: Includes the overall dimensions of the selected section and the 
centroid location with respect to both the global origin as well as the local origin. 

• Additional Properties: Includes the radii of gyration and section moduli of the selected 
section. 

• Rebar Properties: Displays the rebar area and rebar ratio in the selected section. 
The following context-sensitive toolbar is available for Section Properties: 

• Zoom In button : Click the Zoom In to zoom in (make the image larger. Zooming 
in can also be done by moving the scroll button on the mouse upwards. 
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• Zoom Out button : Click the Zoom Out button to zoom out (make the image 
smaller). Zooming out can also be done by moving the scroll button on the mouse 
downwards. 

• Rest and Refresh View button : Use this button to restore the original default 
display of the section. 
 

• Add to Report button : Click on this button to add the section properties to the 
detailed report. 

Note: For composite sections, concrete is considered as the base material and the 
transformed section properties are reported. 

5.3. Section Stresses 
After the column section has been created and load combinations have been assigned, CSiCol can 
display Flexural Stress as 2D or 3D color-coded contours on the working area. 

Display stresses on a column section for various load combinations as follows:  

1. Create the column section for which you want to view the Stresses. 

2. Define the load combinations for the section. 

3. Click on the Results Menu> Section> Section> Section Stresses button or the Project 
Explorer> Columns> Results> Section> Section Stresses to view the Section Stresses. 

4. Select the loading and section location from the Section Elastic Stresses grid (Figure 
5.1) that gets activated in the context-sensitive area. 

5. The Stresses can be viewed in 2D or 3D as seen in Figure 5.2 by selecting the desired 
option in the associated context-sensitive toolbar. 

6. The value of stress at any point in the section can also be read by hovering the 
mouse/cursor over the point. A color-coded key is displayed at the extreme right of the 
working area to help interpret the stresses generated on the section. 

The following context-sensitive toolbar is available for Section Stresses: 

• 2D button :  Use this button to view the section stresses in 2D view. 

• 3D button : Use this button to view the section stresses in 3D view. 

• Zoom In button : Click the Zoom In to zoom in (make the image larger. Zooming 
in can also be done by moving the scroll button on the mouse upwards. 

• Zoom Out button : Click the Zoom Out button to zoom out (make the image 
smaller). Zooming out can also be done by moving the scroll button on the mouse 
downwards. 

• Rest and Refresh View button : Use this button to restore the original default 
display of the section stresses. 
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• Add to Report button : Click on this button to add the section stresses to the 
detailed report. 

 

Figure 5.1 Section Elastic Stresses Grid 

 

  

 

a)  b) 

Figure 5.2 Section Flexural Stresses in a) 2D b)3D 
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5.4. Interaction Surface and Curves 
Three stress resultants (axial load, moment about 3-axis and moment about 2-axis) can be 
determined for a particular strain profile on a cross-section. As the strain profile is varied or 
changed, the values of the stress resultants vary. The three stress resultants can be plotted in a 3D 
space to generate a continuous surface for all possible variations of the strain profile on a particular 
cross-section. This is generally known as the stress resultant Interaction Surface.  

In addition, if the strain profiles used to generate the surface are derived from material failure 
conditions, this surface becomes the “Capacity Surface” or the “Failure Surface.” Any combination 
of applied actions P, M3 and M2 that is inside the volume enclosed by this surface is safe, whereas 
any combination that results in a point that is outside this surface is considered unsafe. As the 
interaction surface exists in three-dimensional space, it cannot be plotted on a two-dimensional 
paper space directly. The interaction surface can however be converted to two-dimensional curves 
by appropriate “slicing” of the surface. The two most common types of curves derived from the 
interaction surface are:  

•  Load Moment Interaction Curve (PM Curve): If the capacity surface is sliced 
vertically, along any angle about the origin, we obtain a plot between the resultant 
moment and the axial stress-resultant, often termed the P-M interaction curve. This is 
a very common and useful tool for the design and investigation of columns. Special P-
M curves can be obtained for a slice of the capacity surface along the 3 and 2 axes.  

•  Moment-Moment Interaction Curve (MM Curve): The capacity surface can be 
sliced on the 2-3 plane to obtain the plot between moments M3 and M2. This plot 
between the moment capacity about the 3 and 2 axes provides several useful insights 
into the behavior of the cross-sections. It shows how the moment capacity varies 
around the cross-section at a particular load level. 

5.5. Interaction Diagrams 
The variation of all three parameters governing the section capacity of a column section can be 
plotted in a single 3D graph. This gives an overall picture of the variation of all three parameters 
for the given column section. P is plotted along the vertical axis and M3 and M2 along two 
orthogonal horizontal axes.   

Generate the Interaction Surface for any given column cross-section and display the interaction 
surface and curves of a column section as follows:  

1. Define the column section (geometry and material properties) for which you want to 
generate the surface (see Chapter 3 for more information).   

2. Use the Results Menu> Capacity> Interaction Diagram button or the Project Explorer> 
Columns> Results> Capacity> Interaction Diagram to view the interaction diagrams.  

3. Clicking on this button activates the Interaction Diagram Settings grid in the context-
sensitive area where various settings for the interaction diagram such as the option to 
include or exclude the strength reduction factor, ϕ (or partial safety factors), number 
of curve points and number of curves can be adjusted.  
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4. After making the necessary changes in the Interaction Diagram Settings form, click on 
the Refresh button to update the diagrams. 

Note: The strength reduction factors specific to the design codes can be modified from 
the Options Menu>Strength Reduction Factors (or Partial Safety Factors depending 
on the selected design code). The type of stirrup (tied or spiral) can be selected from 
the Define Menu>Stirrup Type. 

The working area is divided into three sections with associated toolbars that can be used to modify 
the display on each section as seen in Figure 5.3. Each section has been described below with their 
associated toolbars. 

 

 
Figure 5.3 Interaction Diagram Screen 

• Interaction Surface  
The variation of all three parameters governing the section capacity of a column section 
is plotted in a color-coded 3D graph. This gives an overall picture of the variation of 
all three parameters for the given column section. P is plotted along the vertical axis 
and M3 and M2 along two orthogonal horizontal axes. The associated toolbar has the 
following options: 

o Interaction Surface drop-down list : Use the options on 
this drop-down list to set the interaction surface display color for P, M2 or M3. A 
color-coded key is displayed at the extreme right of the section to help interpret the 
values of the selected surface. 

o  Zoom In button : Click the Zoom In button to zoom in (make the image larger). 
Zooming in can also be done by moving the scroll button on the mouse upwards. 

o Zoom Out button : Click the Zoom Out button to zoom out (make the image 
smaller). Zooming out can also be done by moving the scroll button on the mouse 
downwards. 

o Rest and Refresh View button : Use this button to restore the original default 
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display of the interaction surface. 

o Add to Report button : Click on this button to add the interaction surface to 
the detailed report. 

 
• P-M Curve  

P-M curves are outlines obtained when a vertical plane cuts the interaction surface at 
different specified section rotations showing the relationship between the axial load 
and the moment at the specified neutral axis rotation. The associated toolbar has the 
following options: 
 

o Angle drop-down list : This list displays the neutral 
axis angle for the currently displayed P-M curve, and it also displays the user-
specified load combinations for capacity checks. All the defined load combinations 
are listed at the end of the drop-down list. If the section is adequate for the selected 
loading condition, the vector lies within the bounds of the P-M plot. This gives an 
idea of the reserve capacity of the section. Select the neutral axis angle or load 
combination for which you want to view the P-M Curve. The curve display will be 
updated automatically. Move the cursor/mouse pointer over the curve to read the 
values for any point on the curve. 

o Tabulated Output button : Displays the tabulated output of the curve on 
display. The output can be exported to an Excel file by clicking on the Export 
button  or copied to the clipboard by clicking on the Copy button. 

o Add to Report button : Click on this button to add the P-M diagram to the 
detailed report. 

o Interaction Curve Details button : Click on this button to access the Interaction 
Curve Details form which displays details regarding the interaction diagram such 
as angle, maximum capacity in compression and tension and maximum moment 
capacity. 

 
• M-M Curve  

The M-M curves are the horizontal cut surface outlines at certain heights along the 
vertical P axis (specified values of axial load) in P-M2-M3 surface plots. The associated 
toolbar has the following options: 

o Value of Pu edit box : This edit box displays the axial 
load level for the currently displayed M-M curve. Type in the axial load level (Pu) 
for which you want to view the M-M Curve. The curve display will be updated 
automatically.  

o Tabulated Output button : Displays the tabulated output of the curve on 
display. The output can be exported to an Excel file by clicking on the Export 
button  or copied to the clipboard by clicking on the Copy button. 

o Add to Report button : Click on this button to add the M-M diagram to the 
detailed report. 



User’s Manual and Technical Reference Obtain and Interpret Results  

Animate Interaction 55 

 

o Interaction Curve Details button : Click on this button to access the Interaction 
Curve Details form which displays details regarding the interaction diagram such 
as maximum and minimum moment capacities in both axis 2 and 3. 

5.6. Animate Interaction 
Click on the Results Menu> Capacity> Animate Interaction button or the Project Explorer> 
Columns> Results> Capacity> Animate Interaction to view the animation of capacity surface 
generation for different neutral axis angles. The associated toolbars have the following options: 

• Play/Stop button : Click on this button to start the animation. This button changes 

to the Stop button  while the animation is playing. 

• Zoom In button : Click the Zoom In to zoom in (make the image larger. Zooming 
in can also be done by moving the scroll button on the mouse upwards. 

• Zoom Out button : Click the Zoom Out button to zoom out (make the image 
smaller). Zooming out can also be done by moving the scroll button on the mouse 
downwards. 

• Rest and Refresh View button : Use this button to restore the original default 
display of the interaction surface. 

5.7. Capacity Point Details 
Use the Results Menu> Capacity> Capacity Point Details button or the Project Explorer> 
Columns> Results> Capacity> Capacity Point Details to view the capacity point details at several 
points along the P-M diagram at selected neutral axis angle with respect to X-axis or for a specified 
load combination. 

The working area is divided into two sections with associated toolbars. The left section is the P-M 
curve section and the right section is the stress/strain contour section. As you hover along the curve 
points in the P-M curve section, parameters such as Point Status, axial load, major moment, force 
and moment on concrete and rebar, strain, etc are displayed in the context-sensitive Capacity Point 
Details grid whereas the corresponding stress/strain contour is displayed in the stress/strain contour 
section. 

The capacity point details provide important information regarding the various points in the P-M 
diagram. By looking at point status details, it can be determined whether the load point is in 
compression-controlled zone or tension-controlled zone. In the compression-controlled zone, 
failure is initiated by the crushing of concrete at the highly compressed edge while in tension-
controlled zone, failure is initiated by the yielding of the outermost longitudinal bars in the tension 
side of the neutral axis. The rebar strain and rebar force values are useful in determining the type 
of bar lap splicing (compression lap splices or tensile lap splices) required in different zones of the 
P-M diagram. 

The associated toolbar in the P-M curve section has the following options: 
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o Angle drop-down list : This list displays the neutral axis angle for the 
currently displayed P-M curve, and it also displays the user-specified load combinations for 
capacity checks. All the defined load combinations are listed at the end of the drop-down list. If the 
section is adequate for the selected loading condition, the vector lies within the bounds of the P-M 
plot. This gives an idea of the reserve capacity of the section. Select the neutral axis angle or load 
combination for which you want to view the P-M Curve. The curve display will be updated 
automatically. Move the cursor/mouse pointer over the curve to read the values for any point on 
the curve. 

 

o Tabulated Output button : Displays the tabulated output of the curve on display. The output 
can be exported to an Excel file by clicking on the Export button  or copied to the clipboard 
by clicking on the Copy button. 

o Add to Report button : Click on this button to add the capacity point details to the detailed 
report. 

o Interaction Curve Details button : Click on this button to access the Interaction Curve Details 
form which displays details regarding the interaction diagram such as angle, maximum capacity in 
compression and tension and maximum moment capacity. 
 

The associated toolbar in the stress/strain contour section has the following options: 

• 2D button :  Use this button to view the stress/strain contour in 2D view. 

• 3D button : Use this button to view the stress/strain contour in 3D view. 

• Type of Contour drop-down list : Use this drop-down list to 
select which contour is to be displayed. The options are concrete stress, bar stress, 
concrete strain and bar strain. 

5.8. Multiple Curves 
The Multiple Curves feature gives you an idea of the extent of the effect of various parameters such 
as compressive strength of concrete, tensile strength if rebar or the rebar sizes on the capacity of 
the cross-section. It also makes it easier for the designer to determine the most effective way to 
increase the capacity of the section if the section is found to be inadequate for the given load 
combinations. 

Click on the Results Menu> Capacity> Multiple Curves button to access the Multiple Curves form 
that allows the user to plot multiple P-M or M-M diagrams in the same graph with varying values 
for either Compressive Strength of Concrete (fc’), Steel tensile strength (fy) or rebar sizes. Select 
the curve type from the following options: 

• P-M3 (Angle=0): For plotting a P-M diagram at a neutral axis angle of 0 degrees.  
• P-M2 (Angle=90): For plotting a P-M diagram at a neutral axis angle of 90 degrees. 
• P-Mn, for specified neutral axis angle: For plotting a P-M diagram at a specified neutral 

axis angle. Selecting this option requires the user to choose the desired neutral axis 
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angle from a drop-down list. 
• P-Mn, for specified Load Combination: For plotting the P-M diagram for the specified 

load combination. Selecting this option requires the user to choose the desired load 
combination from a drop-down list. All the load combinations defined earlier will be 
available in the drop-down list.  

• M3-M2, for specified value of axial load (Pu): For plotting the M-M curve at a 
specified value of axial load. Selecting this option requires the user to input the desired 
axial load (Pu) into the input box. 

Select the parameter you want to vary from the Variable Type list and set the other options as 
required. Click on the Refresh button to view the multiple curves.  

5.9. Design Loads 
Use the Results Menu> Results> Capacity> Design Loads button or the Project Explorer> 
Columns> Results> Capacity> Design Loads to access the Final Design Loads form where the 
final loads considered for the design can be viewed. The final design loads are different from the 
user input loads in case of slender columns as they need to be modified to account for second order 
effects. Select the loading direction (Along X or Along Y) by clicking on the respective tab to view 
the loading in the desired direction. The moments under Along X and Along Y tab correspond to 
the moment about the X-axis and the Y- axis respectively. 

5.10. Design Loads 
Use the Results Menu>Results>Design Loads button or the Project 
Explorer>Columns>Results>Design Loads to access the Design Loads form where the final loads 
considered for the design can be viewed. The final design loads are different from the user input 
loads in case of slender columns as they need to be modified to account for second order effects. 
Select the loading direction (Along X or Along Y) by clicking on the respective tab to view the 
loading in the desired direction. The moments under Along X and Along Y tab correspond to the 
moment about the X-axis and the Y- axis respectively. 

5.11. Capacity Ratio Calculation 
After a section has been defined (geometry and material properties), it is checked against all 
specified load combinations for adequacy on the basis of the capacity ratio. The capacity ratio is 
the ratio between the applied actions to the corresponding capacity of the cross-section. The 
capacity ratio is easy to define when there is one independent action and the corresponding capacity 
as in the case of a beam. But for a column cross-section with axial loads and moments about 2 axes 
acting simultaneously on it, the capacity and the capacity ratio are not easy to define. Several 
capacities and capacity ratios can be defined and computed. CSiCol calculates the capacity ratios 
by the following different methods: 

• Moment Sum at P: It is defined as the sum of individual ratios between the applied 
moment and the maximum moment capacity about each axis for the given axial load 
(Pu) as seen in Figure 5.4. The moment capacity is determined by cutting the capacity 
interaction surface at the given axial load to get a M-M interaction curve.  
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Figure 5.4 Capacity Ratio Based on Moment Sum at P 

• Moment Vector at P: It is defined as the ratio of the length of moment vector to the 
moment capacity vector at the axial load (Pu) as seen in Figure 5.5. The moment 
capacity is determined by cutting the capacity interaction surface at the given axial 
load to get a M-M interaction curve.  

 

 

Figure 5.5 Capacity Ratio Based on Moment Vector at P 

• Axial P Compression: It is defined as the ratio between the compressive axial load and 
the maximum compressive axial load capacity in the absence of any moments. 
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• Axial P Tension: It is defined as the ratio between the tensile axial load and the 
maximum tensile axial load capacity in the absence of any moments. 
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• PM Vector: It is defined as the ratio of the length of applied action vector to the 
capacity vector along the same direction as seen in Figure 5.6 
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Figure 5.6 
Capacity 

Ratio 
Based on 
PM Vector 

5.12. Capacity Ratios Results 
The results are displayed in terms of capacity ratio. Results are displayed separately for the top and 
bottom ends and for combined effects in both directions of the column. The form is displayed in 
Figure 5.7. 

Display the capacity calculation ratio as follows:   

1. Define the column cross-section for which you want to check the capacity.   

2. Click the Results Menu> Results> Capacity> Capacity Ratios button to access the 
Capacity Calculation Result form. The form may also be accessed using the Project 
Explorer> Columns> Results> Capacity> Capacity Ratios 

The maximum of the capacity ratios calculated from different methods for the bottom and top ends 
of the section are displayed in two separate tabs. It also displays whether the section is adequate 
for each load combination or not. For maximum capacity ratios greater than one, the software 
reports the section as inadequate. The output can be exported to an Excel file by clicking on the 
Export button  or copied to the clipboard by clicking on the Copy button. 
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Figure 5.7 Capacity Calculation Results Form 

Note: The capacity ratio calculated using the “Moment Sum at P” and “PM Vector” 
methods are excluded while determining the maximum capacity ratio. 

5.13. Detailed Results 
The detailed results can be accessed by using the Results Menu> Results> Detailed Results button 
or the Project Explorer> Columns> Results> Detailed Results. The detailed Capacity Calculation 
Results form (Figure 5.8) displays some additional results besides the maximum capacity ratios 
such as the resultant moment and resultant moment angle, capacity ratios calculated from all the 
methods for each load combination. The output can be exported to an Excel file by clicking on the 
Export button  or copied to the clipboard by clicking on the Copy button. 
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Figure 5.8 Detailed Capacity Calculation Results Form 

Note: If the specified axial load is greater than the maximum axial load capacity, the capacity ratios 
based on “Moment Sum at P” and “Moment Vector at P” show very large values (200 and 100 
respectively) indicating that the section is inadequate. 

5.14. Stress Strain for Loading 
Click on the Results>Capacity>Stress Strain for Loading button or the Project 
Explorer>Columns>Results>Capacity>Stress Strain for Loading to view the stress/strain contours 
in concrete and reinforcement as well as the orientation and the location of the neutral axis for a 
selected load combination. The associated toolbar has the following options: 

• Load Combination Drop-down list : Select the desired load 
combination from this drop-down list.   

• 2D button :  Use this button to view the stress/strain contour in 2D view.   

• 3D button : Use this button to view the stress/strain contour in 3D view.  

• Type of Contour drop-down list : Use this drop-down list to 
select which contour is to be displayed. The options are concrete stress, bar stress, 
concrete strain and bar strain. 

5.15. Loading Capacity 
Click on the Results>Capacity>Loading Capacity or the Project Explorer 
Columns>Results>Capacity>Loading Capacity button to view a visual representation of the 
loading and capacity of the selected column section in 3D and 2D. The associated toolbar has the 
following options: 
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• Load Combination Drop-down list : Select the desired load 
combination from this drop-down list. 

• Show Loading/Capacity Drop-down list : Use this drop- 
down list to choose whether to view loading or capacity or both. 

5.16. Moment Curvature 
Moment curvature diagram is the graphical representation of moment resistance at a section with 
respect to the curvature. A moment-curvature diagram obtained from the stress resultants are 
independent of the member geometry or the bending moment diagram and for a specified axial 
load, it is the property of the cross-section.  

The moment-curvature relation is an important input for nonlinear static and nonlinear dynamic 
analyses of structures including the evaluation of post-elastic behavior and determination of the 
rotational capacity of plastic hinges formed during high seismic activity. This relationship is also 
the basis for the capacity-based and performance-based design methods.  

The software is capable of plotting moment-curvature curves for a section. Click the Results Menu> 
Results> Moment Curvature> Moment Curvature button or the Project Explorer> Columns> 
Results> Moment Curvature> Moment Curvature to activate the Moment Curvature Diagram in 
the working area as seen in Figure 5.9. Clicking on this button activates the Diagram grid (Figure 
5.10) where various settings for the calculation of the moment-curvature diagram such as neutral 
axis angle, axial load, maximum compression and tension strains, maximum curvature and number 
of curve points can be adjusted can be adjusted. After the necessary changes have been made in 
this grid, click on the Refresh button to update the diagram. The associated toolbar has the following 
options: 

• Curve Type Drop-down list : Click on this drop-
down list to select the type of graph to be displayed. The options available are Moment 
vs Curvature, Compressive Steel Force vs Curvature, Concrete Force vs Curvature, 
Maximum Steel Strain vs Curvature, Maximum Concrete Strain vs Curvature and 
Neutral Axis vs Curvature graphs.  
 
There is an additional option in the toolbar for Compressive Steel Force vs Curvature, 
Concrete Force vs Curvature, Maximum Steel Strain vs Curvature and Maximum 
Concrete Strain vs Curvature diagrams which allows you to view the diagrams 
considering compression to be negative. CSiCol considers compression to be positive 
but for the moment curvature diagrams, this option provides a functionality to change 
the sign convention. 

• Change sign convention button : Click on the +ve sign or -ve sign to 
consider compression as positive or negative respectively. 
There is an additional option in the toolbar for Neutral Axis vs Curvature diagram 
which allows you to select whether the neutral axis depth is considered from the top 
of the section or from the centroid of the section. 
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• Neutral Axis Depth button : Click on the YNA button to consider the 
neutral axis depth from the centroid of the section and the NA button to consider the 
neutral axis depth from the top of the section. 

• Tabulated Output button : Displays the tabulated output of the curve on display. 
The output can be exported to an Excel file by clicking on the Export button  
or copied to the clipboard by clicking on the Copy button. 

• Add to Report button : Click on this button to add the Moment Curvature diagram 
to the detailed report. 

• Curve Details button : Click on this button to access the Curve Details form which 
displays details regarding the moment curvature diagram such as cross section angle, 
axial load capacity, initial stiffness and ductility ratio. 
 

 

Figure 5.9 Moment Curvature Diagram 
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Figure 5.10 Diagram Grid 

Note: The curves are primarily intended for reinforced concrete sections and composite sections 
(Concrete sections with steel) 

5.17. Moment Curvature Details 
Use the Results Menu> Results> Moment Curvature> Moment Curvature Details button or the 
Project Explorer> Columns> Results> Moment Curvature> Moment Curvature Details to view 
moment-curvature details at several points along the curve. The working area is divided into two 
sections with associated toolbars. The left section is the moment curvature section and the right 
section is the stress/strain contour section. As you hover along the curve points in the moment 
curvature section, parameters such as Point Status, force details, moment, curvature, strain values, 
neutral axis depth and stiffness values are displayed in the context-sensitive grid whereas the 
neutral axis depth and stress/strain contours are displayed in the stress/strain contour section. 

The associated toolbar has the following options: 

• Curve Type Drop-down list : Click on this drop-
down list to select the type of graph to be displayed. The options available are Moment 
vs Curvature, Compressive Steel Force vs Curvature, Concrete Force vs Curvature, 
Maximum Steel Strain vs Curvature, Maximum Concrete Strain vs Curvature and 
Neutral Axis vs Curvature graphs. 
There is an additional option in the toolbar for Compressive Steel Force vs Curvature, 
Concrete Force vs Curvature, Maximum Steel Strain vs Curvature and Maximum 
Concrete Strain vs Curvature diagrams which allows you to view the diagrams 
considering compression to be negative. CSiCol considers compression to be positive 
but for the moment curvature diagrams, this option provides a functionality to change 
the sign convention. 

• Change sign convention button : Click on the +ve sign or -ve sign to 
consider compression as positive or negative, respectively. 
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There is an additional option in the toolbar for Neutral Axis vs Curvature diagram 
which allows you to select whether the neutral axis depth is considered from the top 
of the section or from the centroid of the section. 

• Neutral Axis Depth button : Click on the YNA button to consider the 
neutral axis depth from the centroid of the section and the NA button to consider the 
neutral axis depth from the top of the section. 

 

• Value of Pu edit box : This edit box displays the axial load 
level for the currently displayed curve. Type in the axial load level (Pu) for which you 
want to view the curve and click on the Refresh button. 

• Angle drop-down list : This list displays the neutral axis 
angle for the currently displayed curve. Select the neutral axis for which you want to 
view the curve and click on the Refresh button. 

• Refresh button : Click on this button to update the displayed curve after changing 
the Pu or Angle values. 

• Tabulated Output button : Displays the tabulated output of the curve on display. 
The output can be exported to an Excel file by clicking on the Export button  
or copied to the clipboard by clicking on the Copy button.  

• Add to Report button : Click on this button to add the Moment Curvature diagram 
to the detailed report. 

• Curve Details button : Click on this button to access the Moment Curvature details 
form which displays details regarding the moment curvature diagram such as cross 
section angle, axial load capacity, initial stiffness and ductility ratio. 

5.18. Max Curvature Plot 
Use the Results Menu>Moment Curvature>Max Curvature Plot or the Project 
Explorer>Columns>Results> Moment Curvature>Max Curvature Plot button to view the 
Maximum Curvature plot.  

Clicking on this button activates the Diagram grid in the context-sensitive area where various 
parameters for the max curvature plot such as maximum compression strain, maximum tension 
strain, maximum curvature, maximum curvature factor and number of curve points can be adjusted. 
After making the necessary changes in this grid, click on the Refresh button to update the diagrams.  

The working area is divided into three sections with associated toolbars that can be used to modify 
the display on each. Each section has been described below with their associated toolbars. 

5.18.1. Maximum Curvature Surface  

The variation of all three parameters governing the maximum curvature surface (axial load, 
curvature 2 and curvature 3) is plotted in a color-coded 3D graph. This gives an overall picture of 
the variation of all three parameters for the given column section. Axial load is plotted along the 
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vertical axis and curvatures along two orthogonal horizontal axes. A color-coded key is displayed 
at the extreme right of the section to help interpret the axial load values. 

5.18.2. Axial Load vs Curvature Curve  

The associated toolbar has the following options: 

• Angle drop-down list : This list 
displays the neutral axis angle for the currently displayed 
curve. Select the neutral axis for which you want to view 
the curve. The curve display will be updated automatically. 
Move the cursor/mouse pointer over the curve to read the 
values for any point on the curve. 

• Tabulated Output button : Displays the tabulated 
output of the curve on display. The output can be exported 
to an Excel file by clicking on the Export button  
or copied to the clipboard by clicking on the Copy button. 

 

• Add to Report button : Click on this button to add the 
axial load vs curvature diagram to the detailed report. 

5.18.3. Curvature-Curvature Curve  

This view shows a variation of curvature, for a selected value of axial load for various angles of 
neutral axis.  

The associated toolbar has the following options: 

• Value of Pu edit box : This edit box displays the axial load level 
for the currently displayed curvature-curvature curve. Type in the axial load level (Pu) for which 
you want to view the curve. The curve display will be updated automatically.  

 

• Tabulated Output button : Displays the tabulated output of the curve on display. The output 
can be exported to an Excel file by clicking on the Export button  or copied to the clipboard 
by clicking on the Copy button. 

• Add to Report button : Click on this button to add the curvature-curvature diagram to the 
detailed report. 

5.18.4. Maximum Curvature Surface:  

The variation of all three parameters governing the maximum curvature surface (axial load, 
curvature 2 and curvature 3) is plotted in a color-coded 3D graph. This gives an overall picture of 
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the variation of all three parameters for the given column section. Axial load is plotted along the 
vertical axis and curvatures along two orthogonal horizontal axes. A color-coded key is displayed 
at the extreme right of the section to help interpret the axial load values. 

5.18.5. Axial Load vs Curvature Curve  

The associated toolbar has the following option: 

• Angle drop-down list : This list displays the neutral axis 
angle for the currently displayed curve. Select the neutral axis for which you want to 
view the curve. The curve display will be updated automatically. Move the 
cursor/mouse pointer over the curve to read the values for any point on the curve. 

• Tabulated Output button : Displays the tabulated output of the curve on display. 
The output can be exported to an Excel file by clicking on the Export button  
or copied to the clipboard by clicking on the Copy button. 

 

• Add to Report button : Click on this button to add the axial load vs curvature 
diagram to the detailed report. 

5.18.6. Curvature-Curvature Curve  

This view shows a variation of curvature, for a selected value of axial load for various angles of 
neutral axis.  

The associated toolbar has the following options: 

• Value of Pu edit box : This edit box displays the axial load level 
for the currently displayed curvature-curvature curve. Type in the axial load level (Pu) for which 
you want to view the curve. The curve display will be updated automatically.  

 

• Tabulated Output button : Displays the tabulated output of the curve on display. The output 
can be exported to an Excel file by clicking on the Export button  or copied to the clipboard 
by clicking on the Copy button. 

• Add to Report button : Click on this button to add the curvature-curvature diagram to the 
detailed report. 

5.19. Axial Load Strain Plot 
Use the Results Menu>Moment Curvature>Axial Load Strain or the Project 
Explorer>Columns>Results> Moment Curvature>Axial Load Strain button to plot axial load vs 
strain curve for the selected section. Clicking on this button activates the Diagram grid in the 
context-sensitive area where various settings for the calculation of the axial load strain diagram 
such as maximum strains and number of curve points can be adjusted. After the necessary changes 
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have been made in this form, click on the Refresh button to update the diagram. The associated 
toolbar has the following options: 

• Add to Report button : Click on this button to add the Axial Load vs Strain diagram 
to the detailed report. 
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 Generate a Report 

6.1. Overview 
This chapter describes the procedure for viewing and printing a report. The report automatically 
takes into consideration the currently selected code and updates the reporting accordingly. 
Therefore, the content of the report for various codes may differ, but the procedure for viewing and 
printing the report remains unchanged. 

6.2. Viewing Report 
Report can be viewed by selecting any of the different types of report available under Project 
Explorer>Report or under Results Menu>Reports. There are 3 different options available: 

• Column Summary 
• Simple Report 
• Detailed Report 

6.3. Column Summary 
Use the Results Menu>Reports>Column Summary button or the Project Explorer> Report> 
Column Summary to access the Summary form (Figure 6.1) which summarizes some critical 
information regarding all the columns in the Project File such as the governing load, the rebar 
configuration, rebar ratio and the corresponding D/C ratio. 
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Figure 6.1 Column Summary Form 

6.4. Simple Report 
Use the Results Menu>Reports>Simple Report button or the Project Explorer>Report>Simple 
Report to generate a one-page report (Figure 6.2) for each of  the columns in the Project File. The 
one-page report contains details regarding the column such as section properties, material 
properties, rebar details and the governing load combination. It also includes the PM diagram and 
MM diagram. The various options available in the context-sensitive toolbar of the Simple Report 
are: 

• Zoom Level Drop-Down List : Select a zoom level from 
this drop-down list to view the report at the desired zoom level. 

• Zoom In button : Click the Zoom In button to zoom in (make the image larger).  

• Zoom Out button : Click the Zoom Out button to zoom out (make the image 
smaller).  

• Rest and Refresh View button : Use this button to restore the original default 
display of the report. 

• Print button : Click on this button to print the Report. 
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Figure 6.2 Simple Report 

6.5. Detailed Report 
Use the Home Menu>Results and Reports>Detailed Report button or the Project 
Explorer>Report>Detailed Report to access the detailed report for all the columns in the Project 
File. The detailed report includes Project Information, Column Section diagrams, Materials 
properties, Stress-strain model parameters, Rebar properties, Section properties, Framing (in case 
of slender columns), Loadings and Design information. The various options available in the 
context-sensitive toolbar of the Detailed Report are: 

• Zoom Level Drop-Down List : Select a zoom level from 
this drop-down list to view the report at the desired zoom level. 

• Zoom In button : Click the Zoom In button to zoom in (make the image larger).  

• Zoom Out button : Click the Zoom Out button to zoom out (make the image 
smaller).  
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• Rest and Refresh View button : Use this button to restore the original default 
display of the interaction surface. 

• Print button : Click on this button to print the report. 

6.6. Adding to the Detailed Report  
Additional graphics can be added to the report at any time before printing by clicking on the Add 

to Report button  available in the context-sensitive toolbar for all the diagrams in the Results 
Menu.  

6.7. Printing or Saving a Report 
The Simple Report and the Detailed Report can be printed by clicking on the Print button  
available in the associated context-sensitive toolbar of the Report. The report can be saved by 
printing it to PDF format. 
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Appendix A – Transformed Property Examples 

Overview 
This Appendix gives examples for common situations where multiple shapes overlap and how the different 
material properties and shapes are handled automatically in the program calculation.    

Transformed Section Properties Calculation 

CASE TYPE DESCRIPTION 

Case 1: Fully overlapping Steel shape 

 

• Overlapping region is accounted for 

• The overlapping region of steel shape is 
subtracted from the base concrete shape (Shape 
1) and the resulting polygon is added to the main 
mesh 

• The steel shape is then added to the main mesh 

• Since both shapes have different material, 
modular ratio = 8.06 

 

• Area = 24*36-180 + 8.06*180 = 2134 in2 

 

Shape 1 
Shape 2 

36000 psi 
4000 psi BAS
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Case 2: Fully overlapping concrete shape w/ same 
material 

 

• Overlapping region is accounted for 

• The overlapping region is subtracted from the 
base concrete shape (Shape 1) and the resulting 
polygon is added to the main mesh 

• Shape 2 is then added to the main mesh 

• Since both shapes have the same material, 
modular ratio =1 

 

• Area = = 24*36-15*25 +1*15*25 = 864 in2 

 

Case 3: Fully overlapping concrete shape w/ different 
material 

 

• Overlapping region is accounted for 

• The overlapping region is subtracted from the 
base concrete shape (Shape 1) and the resulting 
polygon is added to the main mesh 

• Shape 2 is then added to the main mesh 

• Since both shapes have different material, 
modular ratio =1.22 

 

• Area = 24*36-15*25 +1.22*15*25 = 949 in2 

 

Case 4: Partially overlapping concrete shape w/ same 
material 

 

• Overlapping region is accounted for 

• The overlapping region is subtracted from the 
base concrete shape (Shape 1) and the resulting 
polygon is added to the main mesh 

• Shape 2 is then added to the main mesh 

• Since both shapes have the same material, 
modular ratio = 1 

 

• Area = 24*36-9.5*25 + 1*15*25 = 1001 in2 

 

4000 psi 
4000 psi 

6000 psi 
4000 psi 

BAS
 

BAS
 

4000 psi 

4000 psi BAS
 

Shape 1 
Shape 2 

Shape 1 
Shape 2 

Shape 1 
Shape 2 
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Case 5: Partially overlapping concrete shape w/ 
different material 

 

• Overlapping region is accounted for 

• The overlapping region is subtracted from the 
base concrete shape (Shape 1) and the resulting 
polygon is added to the main mesh 

• Shape 2 is then added to the main mesh 

• Since both shapes have different material, 
modular ratio =1.22 

 

• Area = 24*36-9.5*25 + 1.22*15*25 = 1086 in2 

 

6000 psi 

4000 psi BAS
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